fix icecast compile (untested)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2007 21:35:46 +0000 (21:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Dec 2007 21:35:46 +0000 (21:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9878 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/icecast/Makefile
net/icecast/libvorbisidec.mk [new file with mode: 0644]

index 2511afc..62a9219 100644 (file)
@@ -21,6 +21,9 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
+TREMOR_BUILD_DIR=$(PKG_BUILD_DIR)/libvorbisidec-1.2.0-dave
+TREMOR_DIR=$(TREMOR_BUILD_DIR)/ipkg-install/usr
+
 define Package/icecast
   SECTION:=net
   CATEGORY:=Network
@@ -39,23 +42,35 @@ define Package/icecast/description
        interaction.
 endef
 
+define Build/Prepare
+       $(Build/Prepare/Default)
+       $(SUBMAKE) -f libvorbisidec.mk \
+               BUILD_DIR="$(PKG_BUILD_DIR)" \
+               V=99 \
+               prepare
+endef
 
 define Build/Configure
+       $(MAKE) -f libvorbisidec.mk \
+               BUILD_DIR="$(PKG_BUILD_DIR)" \
+               V=99 \
+               compile
+       $(SED) 's,-lvorbisidec,$(TREMOR_DIR)/lib/libvorbisidec.a,g' $(PKG_BUILD_DIR)/configure
        $(call Build/Configure/Default, \
                --enable-yp \
                --with-curl="yes" \
                --with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
-               --with-ogg="$(STAGING_DIR)/usr" \
+               --with-ogg="$(TREMOR_DIR)" \
                --with-speex="no" \
                --with-theora="no" \
-               --with-vorbis="$(STAGING_DIR)/usr" \
+               --with-vorbis="$(TREMOR_DIR)" \
                --with-xslt-config="$(STAGING_DIR)/usr/bin/xslt-config" \
                , \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 " \
+               CPPFLAGS="-I$(TREMOR_DIR)/include -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/libxml2 " \
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
diff --git a/net/icecast/libvorbisidec.mk b/net/icecast/libvorbisidec.mk
new file mode 100644 (file)
index 0000000..6438b12
--- /dev/null
@@ -0,0 +1,42 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbisidec
+PKG_VERSION:=1.2.0-dave
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
+PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PATCH_DIR=./patches-libvorbisidec
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-shared \
+               --enable-static \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       true
+endef
+
+$(eval $(call Build/DefaultTargets))