this patch adds geftpserver package.
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:53:31 +0000 (04:53 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 04:53:31 +0000 (04:53 +0000)
-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19771 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/gesftpserver/Makefile [new file with mode: 0644]

diff --git a/net/gesftpserver/Makefile b/net/gesftpserver/Makefile
new file mode 100644 (file)
index 0000000..b639db2
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sftpserver
+PKG_REV:=228
+PKG_VERSION:=r$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.greenend.org.uk/rjk/bzr/sftpserver.dev
+PKG_SOURCE_PROTO:=bzr
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+PKG_INSTALL:=1
+
+TAR_OPTIONS:=--transform='s,$(PKG_NAME),$(PKG_NAME)-$(PKG_VERSION),' -xvf -
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gesftpserver
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread +libiconv
+  TITLE:=SFTP server
+  URL:=http://www.greenend.org.uk/rjk/sftpserver/
+endef
+
+define Package/gesftpserver/description
+This is an experimental free SFTP server. It is currently still under development
+(so don't trust it with critical data). It should be possible to use it as a
+drop-in replacement for the widely-used OpenSSH SFTP server. It does not include
+an SSH server, but rather runs as a subsystem of one.
+endef
+
+CONFIGURE_CMD:=./prepare
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib \
+       -lpthread
+
+define Package/gesftpserver/install    
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/gesftpserver $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,gesftpserver))