packages/vnstat: rename uci config file, cleanup
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Nov 2011 11:49:05 +0000 (11:49 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Nov 2011 11:49:05 +0000 (11:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29229 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/vnstat/Makefile
net/vnstat/files/vnstat-uci.conf [deleted file]
net/vnstat/files/vnstat.config [new file with mode: 0644]

index efabd17..a3c07c7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vnstat
 PKG_VERSION:=1.11
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://humdi.net/vnstat
@@ -80,13 +80,13 @@ endef
 
 define Package/vnstat/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vnstat $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/vnstat $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/vnstatd $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/vnstatd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vnstat.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/vnstat-uci.conf $(1)/etc/config/vnstat
+       $(INSTALL_CONF) ./files/vnstat.config $(1)/etc/config/vnstat
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/vnstat.init $(1)/etc/init.d/vnstat
        $(INSTALL_DIR) $(1)/etc/uci-defaults
@@ -95,7 +95,7 @@ endef
 
 define Package/vnstati/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vnstati $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/vnstati $(1)/usr/bin/
 endef
 
 define Package/vnstat/postinst
diff --git a/net/vnstat/files/vnstat-uci.conf b/net/vnstat/files/vnstat-uci.conf
deleted file mode 100644 (file)
index 9da71ed..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config vnstat
-       list interface          br-lan
-#      list interface          eth0.1
-#      option remote           http://example.org/vnstat/
-#      option symlink          /www/vnstat
diff --git a/net/vnstat/files/vnstat.config b/net/vnstat/files/vnstat.config
new file mode 100644 (file)
index 0000000..9da71ed
--- /dev/null
@@ -0,0 +1,5 @@
+config vnstat
+       list interface          br-lan
+#      list interface          eth0.1
+#      option remote           http://example.org/vnstat/
+#      option symlink          /www/vnstat