openssh: do not touch /etc/services
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 19:56:43 +0000 (19:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 19:56:43 +0000 (19:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26149 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openssh/Makefile

index 57fe655..8281de7 100644 (file)
@@ -178,11 +178,6 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
        echo "adding user $$name to /etc/passwd"
        echo "$${name}:x:$${id}:$${id}:$${name}:/var/empty/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
-
-grep -q '^ssh[[:space:]]*22/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $$? -ne 0 ]; then
-echo "ssh           22/tcp" >>$${IPKG_INSTROOT}/etc/services
-fi
 endef
 
 define Package/openssh-sftp-client/install