[packages] python-pydaemon: add package python-pydaemon
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Oct 2012 16:27:21 +0000 (16:27 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Oct 2012 16:27:21 +0000 (16:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33812 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/python-pydaemon/Makefile [new file with mode: 0644]

diff --git a/lang/python-pydaemon/Makefile b/lang/python-pydaemon/Makefile
new file mode 100644 (file)
index 0000000..9ddd233
--- /dev/null
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pydaemon
+PKG_VERSION:=0.2.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://wookr.com/pydaemon/dl/
+#PKG_MD5SUM:=24dad7edc5ada31dddd49456ee8d5254
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-pydaemon
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=python-pydaemon
+  URL:=http://wookr.com/pydaemon
+  DEPENDS:=+python +python-rsfile
+  MAINTAINER:=Hamish Guthrie <hcg@openwrt.org>
+endef
+
+define Package/python-pydaemon/description
+  Turn python scripts into Unix daemons
+endef
+
+define Build/Compile
+       $(INSTALL_DIR) $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/pydaemon
+       $(CP) \
+               $(PKG_BUILD_DIR)/src/pydaemon \
+                       $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)
+endef
+
+define Package/python-pydaemon/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)/pydaemon
+       $(CP) \
+               $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/pydaemon \
+               $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-pydaemon))