[packages] sox: depends on alsa-lib and libsndfile
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jun 2012 00:22:26 +0000 (00:22 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jun 2012 00:22:26 +0000 (00:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32317 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mocp/Makefile
sound/sox/Makefile

index c343776..4875adf 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/moc
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg
+  DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg-mini
   TITLE:=Music On Console
   URL:=http://moc.daper.net/
 endef
index 30e78f0..ee501f8 100644 (file)
@@ -30,7 +30,7 @@ TARGET_LDFLAGS+= \
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm
+  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm +alsa-lib +libsndfile
   TITLE:=Sox is a general purpose sound converter/player/recorder
   URL:=http://sox.sourceforge.net/
 endef