uob-nomad: clean the tree to avoid packaging precompiled binaries, fix passing openwr...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 23:30:15 +0000 (23:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 23:30:15 +0000 (23:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32234 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/uob-nomad/Makefile

index 8435dac..cdf673c 100644 (file)
@@ -38,12 +38,15 @@ This is an implementation of NOMADv4 (Filters for
        status information to the UoB-NOMAD-GUI (ver 0.1).
 endef
 
+MAKE_FLAGS = \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+
 define Build/Compile
-$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Agent mipagent)
+$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Agent clean mipagent)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools clean)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools/lib clean)
 $(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client/net-tools all)
-$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client mipmn)
+$(call Build/Compile/Default,-C $(PKG_BUILD_DIR)/Client clean mipmn)
 endef
 
 define Package/uob-nomad/install