ruby: disable documentation for host build
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:27 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:27 +0000 (00:56 +0000)
Building the documentation for the host requires a bunch of tools that systems
might not have, simply disable it which also speeds up the build time.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39796 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/ruby/Makefile

index c53937b..7b67ebe 100644 (file)
@@ -202,6 +202,10 @@ $(call Package/ruby/Default)
   DEPENDS:=ruby +zlib
 endef
 
+HOST_CONFIGURE_ARGS += \
+       --disable-install-doc \
+       --disable-install-rdoc \
+       --disable-install-capi
 
 CONFIGURE_ARGS += \
        --enable-shared \