[packages] wide-dhcpv6: fix second instance of endian detection as well (#10648)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Dec 2011 19:20:09 +0000 (19:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Dec 2011 19:20:09 +0000 (19:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29589 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/wide-dhcpv6/Makefile
ipv6/wide-dhcpv6/files/dhcp6c.init

index bdb74cc..04f1326 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wide-dhcpv6
 PKG_VERSION:=20080615
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index b60b45b..1224810 100644 (file)
@@ -51,7 +51,7 @@ dhcp6c_write_duid() {
                        local len_lo=$(printf "%02x" $((${#len_id} % 0xFF)) )
 
                        # low endian
-                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "%04x"')" = "0001" ]; then
+                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "" "%04x" ""')" = "0001" ]; then
                                printf \\x$len_lo\\x$len_hi
 
                        # big endian