libxml2: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Jul 2014 10:29:07 +0000 (10:29 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Jul 2014 10:29:07 +0000 (10:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41741 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libxml2/Makefile [deleted file]

diff --git a/libs/libxml2/Makefile b/libs/libxml2/Makefile
deleted file mode 100644 (file)
index 1c9527b..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libxml2
-PKG_VERSION:=2.9.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://gd.tuwien.ac.at/languages/libxml/ \
-       http://xmlsoft.org/sources/ \
-       ftp://fr.rpmfind.net/pub/libxml/
-PKG_MD5SUM:=9c0cfef285d5c4a5c80d00904ddab380
-
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=COPYING
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libxml2
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Gnome XML library
-  URL:=http://xmlsoft.org/
-  DEPENDS:=+libpthread +zlib
-endef
-
-define Package/libxml2/description
-  A library for manipulating XML and HTML resources.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --with-c14n \
-       --without-catalog \
-       --with-debug \
-       --without-docbook \
-       --with-html \
-       --without-ftp \
-       --without-http \
-       --without-iconv \
-       --without-iso8859x \
-       --without-legacy \
-       --with-output \
-       --without-pattern \
-       --without-push \
-       --without-python \
-       --with-reader \
-       --without-readline \
-       --without-regexps \
-       --with-sax1 \
-       --with-schemas \
-       --with-threads \
-       --with-tree \
-       --with-valid \
-       --with-writer \
-       --with-xinclude \
-       --with-xpath \
-       --with-xptr \
-       --with-zlib \
-       --without-lzma
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(2)/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(2)/bin/
-       $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(2)/bin/xml2-config
-
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/libxml2 \
-               $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libxml2.{la,a,so*} \
-               $(1)/usr/lib/
-
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxml-2.0.pc \
-               $(1)/usr/lib/pkgconfig/
-
-       $(INSTALL_DIR) $(2)/share/aclocal/
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
-               $(2)/share/aclocal
-endef
-
-define Package/libxml2/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libxml2.so.* \
-               $(1)/usr/lib/
-endef
-
-
-$(eval $(call BuildPackage,libxml2))