php5: temporarily restore pecl.mk to reduce unnecessary oldpackages breakage from...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 20:00:55 +0000 (20:00 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 20:00:55 +0000 (20:00 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42779 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/pecl.mk [new file with mode: 0644]

diff --git a/lang/php5/pecl.mk b/lang/php5/pecl.mk
new file mode 100644 (file)
index 0000000..e1b9819
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2011-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Package/php5-pecl/Default
+  SUBMENU:=PHP
+  SECTION:=lang
+  CATEGORY:=Languages
+  URL:=http://pecl.php.net/
+  MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
+  DEPENDS:=php5
+endef
+
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/usr/bin/phpize )
+       $(Build/Configure/Default)
+endef
+
+CONFIGURE_ARGS+= \
+       --with-php-config=$(STAGING_DIR_HOST)/usr/bin/php-config
+
+define PECLPackage
+
+  define Package/php5-pecl-$(1)
+    $(call Package/php5-pecl/Default)
+    TITLE:=$(2)
+
+    ifneq ($(3),)
+      DEPENDS+=$(3)
+    endif
+  endef
+
+  define Package/php5-pecl-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/php
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/modules/$(subst -,_,$(1)).so $$(1)/usr/lib/php/
+       $(INSTALL_DIR) $$(1)/etc/php5
+    ifeq ($(4),zend)
+       echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php5/$(subst -,_,$(1)).ini
+    else
+       echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php5/$(subst -,_,$(1)).ini
+    endif
+  endef
+
+endef