[packages] tinyproxy: update to 1.8.3
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 00:08:28 +0000 (00:08 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 00:08:28 +0000 (00:08 +0000)
Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@37670 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tinyproxy/Makefile
net/tinyproxy/patches/010-no-docs-and-tests.patch
net/tinyproxy/patches/030-allow_bind_in_transparent_mode.patch
net/tinyproxy/patches/040-fix_url_filter_in_transparent_mode.patch [deleted file]

index a6b61ce..bea3dba 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.8.2
-PKG_RELEASE:=5
+PKG_VERSION:=1.8.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
-PKG_MD5SUM:=edc8502193cfed4974d6a770da173755
+PKG_MD5SUM:=292ac51da8ad6ae883d4ebf56908400d
 
 PKG_INSTALL:=1
 
index 9845c35..cbb0dd1 100644 (file)
@@ -1,30 +1,6 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,9 +2,7 @@ SUBDIRS = \
-       src \
-       data \
-       etc \
--      docs \
-       m4macros \
--      tests
- # tools want this on a single line
- ACLOCAL_AMFLAGS = -I m4macros
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -222,9 +222,7 @@ SUBDIRS = \
-       src \
-       data \
-       etc \
--      docs \
-       m4macros \
--      tests
- # tools want this on a single line
 --- a/configure
 +++ b/configure
-@@ -6816,59 +6816,8 @@ fi
+@@ -6815,59 +6815,8 @@ fi
  
  
  
 -fi
 -
 -if test x"$A2X" = x"no"; then
--  as_fn_error "Test for asciidoc failed. See the file 'INSTALL' for help." "$LINENO" 5
+-  as_fn_error $? "Test for asciidoc failed. See the file 'INSTALL' for help." "$LINENO" 5
 -fi
  
  ac_config_files="$ac_config_files Makefile src/Makefile data/Makefile data/templates/Makefile etc/Makefile docs/Makefile docs/man5/Makefile docs/man5/tinyproxy.conf.txt docs/man8/Makefile docs/man8/tinyproxy.txt m4macros/Makefile tests/Makefile tests/scripts/Makefile"
  
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,9 +2,7 @@ SUBDIRS = \
+       src \
+       data \
+       etc \
+-      docs \
+       m4macros \
+-      tests
+ # tools want this on a single line
+ ACLOCAL_AMFLAGS = -I m4macros
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -222,9 +222,7 @@ SUBDIRS = \
+       src \
+       data \
+       etc \
+-      docs \
+       m4macros \
+-      tests
+ # tools want this on a single line
index 7d6decd..68d89db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/conf.c
 +++ b/src/conf.c
-@@ -857,7 +857,6 @@ static HANDLE_FUNC (handle_deny)
+@@ -865,7 +865,6 @@ static HANDLE_FUNC (handle_deny)
  
  static HANDLE_FUNC (handle_bind)
  {
@@ -8,7 +8,7 @@
          int r = set_string_arg (&conf->bind_address, line, &match[2]);
  
          if (r)
-@@ -865,11 +864,6 @@ static HANDLE_FUNC (handle_bind)
+@@ -873,11 +872,6 @@ static HANDLE_FUNC (handle_bind)
          log_message (LOG_INFO,
                       "Outgoing connections bound to IP %s", conf->bind_address);
          return 0;
diff --git a/net/tinyproxy/patches/040-fix_url_filter_in_transparent_mode.patch b/net/tinyproxy/patches/040-fix_url_filter_in_transparent_mode.patch
deleted file mode 100644 (file)
index ab3118b..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-From e0cf6d4b0c84da6273c127a8c87076aac3b51588 Mon Sep 17 00:00:00 2001
-From: Daniel Egger <daniel.egger@sphairon.com>
-Date: Mon, 16 Aug 2010 22:36:20 +0200
-Subject: [PATCH 3/3] Pass a pointer to a char pointer to do_transparent_proxy so the reassembled URL
- will actually end up back in the caller where it is needed for filtering
- decisions. This fixes the problem that a tinyproxy configured with the
- transparent proxy functionality and "FilterURLs Yes" would filter on everything
- but the domain.
-
-Signed-off-by: daniel.egger@sphairon.com
----
- src/reqs.c              |    2 +-
- src/transparent-proxy.c |   20 ++++++++++----------
- src/transparent-proxy.h |    2 +-
- 3 files changed, 12 insertions(+), 12 deletions(-)
-
---- a/src/reqs.c
-+++ b/src/reqs.c
-@@ -418,7 +418,7 @@ BAD_REQUEST_ERROR:
-         } else {
- #ifdef TRANSPARENT_PROXY
-                 if (!do_transparent_proxy
--                    (connptr, hashofheaders, request, &config, url)) {
-+                    (connptr, hashofheaders, request, &config, &url)) {
-                         goto fail;
-                 }
- #else
---- a/src/transparent-proxy.c
-+++ b/src/transparent-proxy.c
-@@ -55,11 +55,11 @@ static int build_url (char **url, const 
- int
- do_transparent_proxy (struct conn_s *connptr, hashmap_t hashofheaders,
-                       struct request_s *request, struct config_s *conf,
--                      char *url)
-+                      char **url)
- {
-         socklen_t length;
-         char *data;
--        size_t ulen = strlen (url);
-+        size_t ulen = strlen (*url);
-         length = hashmap_entry_by_key (hashofheaders, "host", (void **) &data);
-         if (length <= 0) {
-@@ -73,7 +73,7 @@ do_transparent_proxy (struct conn_s *con
-                                      connptr->client_fd);
-                         indicate_http_error (connptr, 400, "Bad Request",
-                                              "detail", "Unknown destination",
--                                             "url", url, NULL);
-+                                             "url", *url, NULL);
-                         return 0;
-                 }
-@@ -83,15 +83,15 @@ do_transparent_proxy (struct conn_s *con
-                 request->port = ntohs (dest_addr.sin_port);
-                 request->path = (char *) safemalloc (ulen + 1);
--                strlcpy (request->path, url, ulen + 1);
-+                strlcpy (request->path, *url, ulen + 1);
-                 /* url overwritten by the call below is the url passed
-                  * to this function, and is not the url variable in the
-                  * caller. */
--                build_url (&url, request->host, request->port, request->path);
-+                build_url (url, request->host, request->port, request->path);
-                 log_message (LOG_INFO,
-                              "process_request: trans IP %s %s for %d",
--                             request->method, url, connptr->client_fd);
-+                             request->method, *url, connptr->client_fd);
-         } else {
-                 request->host = (char *) safemalloc (length + 1);
-                 if (sscanf (data, "%[^:]:%hu", request->host, &request->port) !=
-@@ -101,15 +101,15 @@ do_transparent_proxy (struct conn_s *con
-                 }
-                 request->path = (char *) safemalloc (ulen + 1);
--                strlcpy (request->path, url, ulen + 1);
-+                strlcpy (request->path, *url, ulen + 1);
-                 /* url overwritten by the call below is the url passed
-                  * to this function, and is not the url variable in the
-                  * caller. */
--                build_url (&url, request->host, request->port, request->path);
-+                build_url (url, request->host, request->port, request->path);
-                 log_message (LOG_INFO,
-                              "process_request: trans Host %s %s for %d",
--                             request->method, url, connptr->client_fd);
-+                             request->method, *url, connptr->client_fd);
-         }
-         if (conf->ipAddr && strcmp (request->host, conf->ipAddr) == 0) {
-                 log_message (LOG_ERR,
-@@ -118,7 +118,7 @@ do_transparent_proxy (struct conn_s *con
-                 indicate_http_error (connptr, 400, "Bad Request",
-                                      "detail",
-                                      "You tried to connect to the machine "
--                                     "the proxy is running on", "url", url,
-+                                     "the proxy is running on", "url", *url,
-                                      NULL);
-                 return 0;
-         }
---- a/src/transparent-proxy.h
-+++ b/src/transparent-proxy.h
-@@ -32,7 +32,7 @@
- extern int do_transparent_proxy (struct conn_s *connptr,
-                                  hashmap_t hashofheaders,
-                                  struct request_s *request,
--                                 struct config_s *config, char *url);
-+                                 struct config_s *config, char **url);
- #endif