ahcp: remove the proto handler script, it seems to be completely useless
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 May 2012 20:58:35 +0000 (20:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 May 2012 20:58:35 +0000 (20:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31728 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcp.sh [deleted file]

index 4d41bdf..41db0d8 100644 (file)
@@ -46,8 +46,6 @@ define Package/ahcpd/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ahcpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/ahcpd.config $(1)/etc/config/ahcpd
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_BIN) ./files/ahcp.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ahcpd.init $(1)/etc/init.d/ahcpd
 endef
diff --git a/ipv6/ahcpd/files/ahcp.sh b/ipv6/ahcpd/files/ahcp.sh
deleted file mode 100644 (file)
index 11788e2..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-setup_interface_ahcp() {
-       local interface="$1"
-       local config="$2"
-
-       setup_interface_none "$interface" "$config"
-
-       local mode=$(uci_get_state ahcpd "@ahcpd[0]" mode "client")
-       if [ "$mode" != "client" ]; then
-               echo "Warning: ahcp ignored for $interface (mode is $mode, should be client)."
-               echo "Fix ahcp mode in /etc/config/ahcpd."
-       else
-               /etc/init.d/ahcpd restart
-       fi
-}