[packages] xtables-addons: the configure first calls "make kernelrelease" which then...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jan 2011 09:57:53 +0000 (09:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jan 2011 09:57:53 +0000 (09:57 +0000)
for the sole purpose of adding the localversion which is then stripped anyway. Let it call "make kernelversion" instead
which does not have such issues. This patch should fix #8535.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24920 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xtables-addons/patches/002-fix-kernel-version-detection.patch [new file with mode: 0644]

diff --git a/net/xtables-addons/patches/002-fix-kernel-version-detection.patch b/net/xtables-addons/patches/002-fix-kernel-version-detection.patch
new file mode 100644 (file)
index 0000000..008f021
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/configure
++++ b/configure
+@@ -10811,7 +10811,7 @@ if grep -q "CentOS release 5\." /etc/red
+ fi;
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
+ $as_echo_n "checking kernel version that we will build against... " >&6; }
+-krel="$(make -sC ${kbuilddir} kernelrelease)";
++krel="$(make -sC ${kbuilddir} kernelversion)";
+ krel="${krel%%-*}";
+ kmajor="${krel%%.*}";
+ krel="${krel#*.}";
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,7 +49,7 @@ if grep -q "CentOS release 5\." /etc/red
+       echo "WARNING: This distribution's shipped kernel is not supported.";
+ fi;
+ AC_MSG_CHECKING([kernel version that we will build against])
+-krel="$(make -sC ${kbuilddir} kernelrelease)";
++krel="$(make -sC ${kbuilddir} kernelversion)";
+ krel="${krel%%-*}";
+ kmajor="${krel%%.*}";
+ krel="${krel#*.}";