Update radvd to 1.8.5
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jul 2012 11:04:04 +0000 (11:04 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jul 2012 11:04:04 +0000 (11:04 +0000)
Radvd has been updated to 1.8.5 a few months ago, while Openwrt still uses
1.8.3. http://www.litech.org/radvd/

This patch updates radvd to 1.8.5. No major changes required.

signed off by: hannu.nyman@iki.fi

I send the patch again to make sure that Windows does not mess with LFs...
(not sure if that is needed, but Patchwork shows the previous one strangely)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32565 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/radvd/Makefile
ipv6/radvd/patches/100-silent-netlink-config-reload.patch

index 5a8aaf4..6fdd505 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
-PKG_VERSION:=1.8.3
-PKG_RELEASE:=3
+PKG_VERSION:=1.8.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
-PKG_MD5SUM:=73d533b7b20f5554c8d3e33643945442
+PKG_MD5SUM:=bdeca76d976282c306f3c454d6ff1f67
 
 PKG_INSTALL:=1
 
index 3439a25..45e3a69 100644 (file)
@@ -1,9 +1,9 @@
 --- a/netlink.c
 +++ b/netlink.c
-@@ -65,7 +65,7 @@ void process_netlink_msg(int sock)
-                 else {
-                         dlog(LOG_DEBUG, 3, "%s, ifindex %d, flags is *NOT* running", ifname, ifinfo->ifi_index);
-                 }
+@@ -63,7 +63,7 @@ void process_netlink_msg(int sock)
+               else {
+                       dlog(LOG_DEBUG, 3, "%s, ifindex %d, flags is *NOT* running", ifname, ifinfo->ifi_index);
+               }
 -              reload_config();
 +              reload_config(LOG_DEBUG);
        }
  
 --- a/radvd.c
 +++ b/radvd.c
-@@ -443,7 +443,7 @@ void main_loop(void)
+@@ -456,7 +456,7 @@ void main_loop(void)
                if (sighup_received)
                {
+                       dlog(LOG_INFO, 3, "sig hup received.\n");
 -                      reload_config();
 +                      reload_config(LOG_INFO);
                        sighup_received = 0;
                }
  
-@@ -551,11 +551,11 @@ stop_adverts(void)
+@@ -565,11 +565,11 @@ stop_adverts(void)
        }
  }
  
@@ -32,9 +32,9 @@
 -      flog(LOG_INFO, "attempting to reread config file");
 +      flog(loglevel, "attempting to reread config file");
  
-       dlog(LOG_DEBUG, 4, "reopening log");
-       if (log_reopen() < 0) {
-@@ -631,7 +631,7 @@ void reload_config(void)
+       iface=IfaceList;
+       while(iface)
+@@ -639,7 +639,7 @@ void reload_config(void)
        config_interface();
        kickoff_adverts();
  
@@ -45,7 +45,7 @@
  void
 --- a/radvd.h
 +++ b/radvd.h
-@@ -186,7 +186,7 @@ int yylex(void);
+@@ -185,7 +185,7 @@ int yylex(void);
  
  /* radvd.c */
  int check_ip6_forwarding(void);
@@ -56,7 +56,7 @@
  /* timer.c */
 --- a/send.c
 +++ b/send.c
-@@ -154,7 +154,7 @@ send_ra(struct Interface *iface, struct 
+@@ -153,7 +153,7 @@ send_ra(struct Interface *iface, struct
                         * reload_config() will kick off new timers anyway.  This avoids
                         * timer list corruption.
                         */