[packages] add disktype (#6613)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 10:20:58 +0000 (10:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Feb 2010 10:20:58 +0000 (10:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19774 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/disktype/Makefile [new file with mode: 0644]

diff --git a/utils/disktype/Makefile b/utils/disktype/Makefile
new file mode 100644 (file)
index 0000000..667efde
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=disktype
+PKG_VERSION:=9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)/
+PKG_MD5SUM:=25a673f162b9c01cd565109202559489
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/disktype
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Disk format detection
+  SUBMENU:=Filesystem
+  URL:=http://disktype.sourceforge.net
+endef
+
+define Package/disktype/description
+       The purpose of disktype is to detect the content format of a disk or disk image.
+       It knows about common file systems, partition tables, and boot codes.
+       The program is written in C and is designed to compile on any modern Unix flavour.
+       It is self-contained and in general works without special libraries or headers.
+       Some system-dependant features can be used to gather additional information.
+endef
+
+MAKE_FLAGS += CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+
+define Package/disktype/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,disktype))