packages/python: add bzip2 module (closes: #9494)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Nov 2011 13:42:14 +0000 (13:42 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Nov 2011 13:42:14 +0000 (13:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29277 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/python/Makefile

index 9a48e80..68d6b6f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python
 PKG_VERSION:=2.6.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
@@ -75,6 +75,12 @@ $(call Package/python/Default)
   DEPENDS+=+python-mini
 endef
 
+define Package/python-bzip2
+$(call Package/python/Default)
+  TITLE:=Python support for Bzip2
+  DEPENDS+=+python-mini +libbz2
+endef
+
 define Package/python-expat
 $(call Package/python/Default)
   TITLE:=Python support for expat
@@ -195,6 +201,7 @@ define PyPackage/python/filespec
 -|/usr/lib/python$(PYTHON_VERSION)/test
 -|/usr/lib/python$(PYTHON_VERSION)/lib2to3
 -|/usr/lib/python$(PYTHON_VERSION)/lib-old
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/bz2.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/gdbm.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_sqlite3.so
 -|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/_ssl.so
@@ -367,6 +374,10 @@ define PyPackage/python-doc/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/pydoc.py
 endef
 
+define PyPackage/python-bzip2/filespec
++|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/bz2.so
+endef
+
 define PyPackage/python-expat/filespec
 +|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/pyexpat.so
 endef
@@ -425,6 +436,7 @@ $(eval $(call HostBuild))
 $(eval $(call PyPackage,python))
 $(eval $(call PyPackage,python-mini))
 $(eval $(call PyPackage,python-doc))
+$(eval $(call PyPackage,python-bzip2))
 $(eval $(call PyPackage,python-expat))
 $(eval $(call PyPackage,python-gzip))
 $(eval $(call PyPackage,python-openssl))
@@ -435,6 +447,7 @@ $(eval $(call PyPackage,python-gdbm))
 $(eval $(call BuildPackage,python))
 $(eval $(call BuildPackage,python-mini))
 $(eval $(call BuildPackage,python-doc))
+$(eval $(call BuildPackage,python-bzip2))
 $(eval $(call BuildPackage,python-expat))
 $(eval $(call BuildPackage,python-gzip))
 $(eval $(call BuildPackage,python-openssl))