[packages] gstreamer: Enable debugging and add gst_log2_debug symbol
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jan 2013 13:20:39 +0000 (13:20 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jan 2013 13:20:39 +0000 (13:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35223 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/gstreamer/Makefile
multimedia/gstreamer/patches/004-add_gst_debug_log2_debug_symbol.patch [new file with mode: 0644]

index 6622c35..a5e896f 100644 (file)
@@ -82,13 +82,9 @@ endef
 GST_VERSION:=0.10
 
 CONFIGURE_ARGS += \
-       --disable-debug \
        --disable-examples \
        --disable-tests \
        --disable-valgrind \
-       \
-       --disable-gst-debug \
-       \
        --without-libiconv-prefix \
        --without-libintl-prefix \
        --without-x \
diff --git a/multimedia/gstreamer/patches/004-add_gst_debug_log2_debug_symbol.patch b/multimedia/gstreamer/patches/004-add_gst_debug_log2_debug_symbol.patch
new file mode 100644 (file)
index 0000000..bc2e9e2
--- /dev/null
@@ -0,0 +1,43 @@
+--- gstreamer-0.10.36/gst/gstinfo.c 2011-12-30 02:14:34.000000000 +0100
++++ gstreamer-0.10.36.modified/gst/gstinfo.c    2013-01-03 14:01:37.000000000 +0100
+@@ -462,6 +462,39 @@
+   va_end (var_args);
+ }
++typedef struct {
++  const gchar *file;
++  const gchar *function;
++  const gint   line;
++} GstDebugTraceLocation;
++
++
++/**
++ * gst_debug_log2:
++ *  <at> category: category to log
++ *  <at> level: level of the message is in
++ *  <at> location: the file, function name, and line number of the location that
++ *    emitted the message
++ *  <at> object: the object this message relates to or NULL if none
++ *  <at> format: a printf style format string
++ *  <at> ...: optional arguments for the format
++ *
++ * Logs the given message using the currently registered debugging handlers.
++ */
++void
++gst_debug_log2 (GstDebugCategory * category, GstDebugLevel level,
++    const GstDebugTraceLocation * location,
++    GObject * object, const gchar * format, ...)
++{
++#if 0
++  va_list var_args;
++
++  va_start (var_args, format);
++  gst_debug_log_valist2 (category, level, location, object, format, var_args);
++  va_end (var_args);
++#endif
++}
++
+ #ifdef _MSC_VER
+ /* based on g_basename(), which we can't use because it was deprecated */
+ static inline const gchar *
+