packages/prosody: move user/group creation from postinst to initscript
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:17:22 +0000 (23:17 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:17:22 +0000 (23:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28901 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/prosody/Makefile
net/prosody/files/prosody.init

index 4c1214c..60ace2b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
 PKG_VERSION:=0.6.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source
@@ -83,43 +83,3 @@ define Package/prosody/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.lua $(1)/usr/lib/prosody/util/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/prosody/util/*.so $(1)/usr/lib/prosody/util/
 endef
-
-define Package/prosody/postinst
-#!/bin/sh
-
-id=54
-name=prosody
-home=/tmp/.$${name}
-shell=/bin/false
-
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-       # create copies of passwd and group, if we use squashfs
-       rootfs=`mount |awk '/root/ { print $$5 }'`
-       if [ "$$rootfs" = "squashfs" ]; then
-               if [ -h /etc/group ]; then
-                       rm /etc/group
-                       cp -p /rom/etc/group /etc/group
-               fi
-               if [ -h /etc/passwd ]; then
-                       rm /etc/passwd
-                       cp -p /rom/etc/passwd /etc/passwd
-               fi
-       fi
-
-       echo ""
-       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-               echo "adding group $$name to /etc/group"
-               echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-       fi
-       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-               echo "adding user $$name to /etc/passwd"
-               echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
-       fi
-
-       chown -R $${name}:$${name} $${IPKG_INSTROOT}/etc/prosody
-fi
-endef
-
-$(eval $(call BuildPackage,prosody))
index 90051c5..af1614d 100644 (file)
@@ -1,7 +1,8 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 
 START=99
+
 EXTRA_COMMANDS="status"
 EXTRA_HELP="   status  Print the status of the service"
 
@@ -13,8 +14,16 @@ RUN_USER=prosody
 RUN_GROUP=prosody
 
 start() {
-       [ -d $LOG_D ] || ( mkdir -p $LOG_D && chown $RUN_USER:$RUN_GROUP $LOG_D )
-       [ -d $RUN_D ] || ( mkdir -p $RUN_D && chown $RUN_USER:$RUN_GROUP $RUN_D )
+       user_exists prosody 54 || user_add prosody 54
+       group_exists prosody 54 || group_add prosody 54
+       [ -d /var/run/prosody ] || {
+               mkdir -m 0755 -p /var/run/prosody
+               chown prosody:prosody /var/run/prosody
+       }
+       [ -d /var/log/prosody ] || {
+               mkdir -m 0755 -p /var/log/prosody
+               chown prosody:prosody /var/log/prosody
+       }
 
        $BIN start
 }