Package: haproxy
authorheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Feb 2011 17:14:36 +0000 (17:14 +0000)
committerheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Feb 2011 17:14:36 +0000 (17:14 +0000)
 - increase default bufsize to 16384 so that
   http error 400 is not thrown any longer due to
   large get requests (reduce this in the global section with (tune.bufsize 8192)
   to save memory
   Thx. to Willy

git-svn-id: svn://svn.openwrt.org/openwrt/packages@25444 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/haproxy/Makefile

index bbc360b..b937db4 100644 (file)
@@ -42,7 +42,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)" \
                LD="$(TARGET_CC)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               SMALL_OPTS="-DBUFSIZE=16060 -DMAXREWRITE=8192 -DSYSTEM_MAXCONN=65530" USE_LINUX_TPROXY=1 \
+               SMALL_OPTS="-DBUFSIZE=16384 -DMAXREWRITE=8192 -DSYSTEM_MAXCONN=65530" USE_LINUX_TPROXY=1 \
                all install
 endef