xinetd: fix compiling without RPC support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2011 18:10:37 +0000 (18:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2011 18:10:37 +0000 (18:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25591 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xinetd/Makefile
net/xinetd/patches/003-rpc_fix.patch [new file with mode: 0644]

index 7385243..e59131d 100644 (file)
@@ -36,6 +36,8 @@ define Package/xinetd/conffiles
 /etc/xinetd.conf
 endef
 
+TARGET_CFLAGS += -DNO_RPC
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libwrap \
diff --git a/net/xinetd/patches/003-rpc_fix.patch b/net/xinetd/patches/003-rpc_fix.patch
new file mode 100644 (file)
index 0000000..d790a89
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/xinetd/confparse.c
++++ b/xinetd/confparse.c
+@@ -716,7 +716,7 @@ static status_e check_entry( struct serv
+          }
+    }
+-/* #ifndef NO_RPC */
++#ifndef NO_RPC
+ #if defined(HAVE_RPC_RPCENT_H) || defined(HAVE_NETDB_H)
+    if ( SC_IS_RPC( scp ) && !SC_IS_UNLISTED( scp ) )
+    {
+@@ -730,6 +730,7 @@ static status_e check_entry( struct serv
+       SC_RPCDATA( scp )->rd_program_number = rep->r_number ;
+    }
+    else
++#endif
+ #endif   /* ! NO_RPC */
+    {
+        if ( !SC_IS_UNLISTED( scp ) )