coreutils: fix build with eglibc
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 13:55:56 +0000 (13:55 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 13:55:56 +0000 (13:55 +0000)
Thank you sav for the patch. (closes #8304)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24166 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/coreutils/Makefile
utils/coreutils/patches/002-fix_compile_with_uclibc.patch

index 2fe2d6e..7103882 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
 PKG_VERSION:=8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/coreutils
@@ -62,11 +62,18 @@ define Package/coreutils/description
         sufficient and much smaller.
 endef
 
+ifneq ($(CONFIG_USE_UCLIBC),)
 CONFIGURE_VARS += \
        gl_cv_func_mbrtowc_incomplete_state=yes \
        gl_cv_func_mbrtowc_retval=yes \
        gl_cv_func_wcrtomb_retval=yes \
        ac_cv_type_pthread_spinlock_t=no
+else
+CONFIGURE_VARS += \
+       gl_cv_func_mbrtowc_incomplete_state=yes \
+       gl_cv_func_mbrtowc_retval=yes \
+       gl_cv_func_wcrtomb_retval=yes
+endif
 
 CONFIGURE_ARGS += \
        --enable-install-program=su
index 537eab3..dffe04e 100644 (file)
@@ -1,10 +1,12 @@
 --- a/lib/pthread.in.h
 +++ b/lib/pthread.in.h
-@@ -225,6 +225,7 @@ pthread_mutex_unlock (pthread_mutex_t *m
+@@ -225,6 +225,9 @@
  
  /* Approximate spinlocks with mutexes.  */
  
++#ifdef __UCLIBC__
 +#define pthread_spinlock_t original_pthread_spinlock_t
++#endif
  typedef pthread_mutex_t pthread_spinlock_t;
  
  static inline int