lm-sensors: moved to github
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Jul 2014 12:43:24 +0000 (12:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Jul 2014 12:43:24 +0000 (12:43 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41463 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/lm-sensors/Makefile [deleted file]
utils/lm-sensors/files/sensors.conf [deleted file]

diff --git a/utils/lm-sensors/Makefile b/utils/lm-sensors/Makefile
deleted file mode 100644 (file)
index 3f14a6d..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lm-sensors
-PKG_VERSION:=3.3.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=lm_sensors-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dl.lm-sensors.org/lm-sensors/releases
-PKG_MD5SUM:=f357ba00b080ab102a170f7bf8bb2578
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/lm_sensors-$(PKG_VERSION)
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/lm-sensors/Default
-  DEPENDS:=+sysfsutils
-  URL:=http://www.lm-sensors.org/
-endef
-
-define Package/lm-sensors
-  $(call Package/lm-sensors/Default)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=lm-sensors
-  DEPENDS+=+libsensors
-endef
-
-define Package/lm-sensors-detect
-  $(call Package/lm-sensors/Default)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=lm-sensors-detect
-  DEPENDS+=+lm-sensors +perl +perlbase-essential +perlbase-fcntl +perlbase-file +perlbase-xsloader
-endef
-
-define Package/libsensors
-  $(call Package/lm-sensors/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libsensors
-endef
-
-define Package/lm-sensors/description
- utility to read hardware sensor data
-endef
-
-define Package/lm-sensors-detect/description
- script to autodetect sensor hardware
-endef
-
-define Package/libsensors/description
- lm-sensors libraries
-endef
-
-define Package/lm-sensors/conffiles
-/etc/sensors.conf
-endef
-
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               KERNELVERSION="$(LINUX_VERSION)" \
-               LINUX="$(LINUX_DIR)" \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               STAGING_DIR="$(STAGING_DIR)" \
-               PREFIX="/usr" \
-               MACHINE="$(ARCH)" \
-               EXLDFLAGS="" \
-               user
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/sensors
-       $(CP) \
-               $(PKG_BUILD_DIR)/lib/sensors.h \
-               $(1)/usr/include/sensors
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) \
-               $(PKG_BUILD_DIR)/lib/libsensors.{a,so*} \
-               $(1)/usr/lib
-endef
-
-define Package/lm-sensors/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/sensors/sensors $(1)/usr/sbin
-ifeq ($(ARCH),i386)
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) ./files/sensors.conf $(1)/etc/sensors.conf
-endif
-endef
-
-define Package/lm-sensors-detect/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/prog/detect/sensors-detect $(1)/usr/sbin
-endef
-
-define Package/libsensors/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/lib/libsensors.so* $(1)/usr/lib
-endef
-
-$(eval $(call BuildPackage,lm-sensors))
-$(eval $(call BuildPackage,lm-sensors-detect))
-$(eval $(call BuildPackage,libsensors))
diff --git a/utils/lm-sensors/files/sensors.conf b/utils/lm-sensors/files/sensors.conf
deleted file mode 100644 (file)
index 505b9d9..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-chip "pc87366-*"
-
-# Soekris net4801 configuration
-
-# Written by Henrik Brix Andersen <henrik@brixandersen.dk>
-# Latest version can be found at http://www.brixandersen.dk/
-
-# The configuration is partly based on the PC87366 datasheet and
-# partly borrowed from the env4801 utility by Poul-Henning
-# Kamp <phk@phk.freebsd.dk>
-
-# Datasheet: http://www.winbond.com/PDF/APCsheet/PC87366.pdf
-# env4801:   http://phk.freebsd.dk/soekris/env4801/
-
-
-# Voltage inputs
-  ignore vid
-
-  # Unknown
-  # label in0     "avi0"
-  ignore in0
-
-
-  # Core Voltage, +2.0V
-  label in1     "VCORE"
-  set in1_min   1.9
-  set in1_max   2.1
-
-
-  # VCC, +5.0V
-  label in2     "VCC"
-  compute in2   @*2, @/2
-
-
-  # Power Supply Input, +6.0V - +28.0V
-  label in3     "VPWR"
-  compute in3   @*20.1, @/20.1
-  set in3_min    6.0
-  set in3_max   28.0
-
-
-  # +12V
-  label in4     "+12V"
-  compute in4   @*4.83, @/4.83
-  set in4_min   11
-  set in4_max   13
-
-
-  # -12V
-  label in5     "-12V"
-  # If in10 on your net4801 doesn't have the 3.3V reference, use this
-  # compute line instead:
-  # compute in5   (@-3.3)*19.2+3.3, (@-3.3)/19.2+3.3
-  compute in5   (@-in10)*19.2+in10, (@-in10)/19.2+in10
-  set in5_min   -13
-  set in5_max   -11
-
-
-  # GND, 0V
-  label in6     "GND"
-  set in6_min   0
-  set in6_max   0
-
-
-  # Standby Voltage, +3.3V
-  # Internally divided by 2
-  label in7     "Vsb"
-  compute in7   @*2, @/2
-  set in7_min    3.0
-  set in7_max    3.6
-
-
-  # Supply Voltage, +3.3V
-  # Internally divided by 2
-  label in8     "Vdd"
-  compute in8   @*2, @/2
-  set in8_min    3.0
-  set in8_max    3.6
-
-
-  # Battery Backup Supply Voltage, +3.0V
-  label in9     "Vbat"
-  set in9_min    2.4
-  set in9_max    3.6
-
-
-  # Analog Supply Voltage, +3.3V
-  # Internally divided by 2
-  label in10    "AVdd"
-  compute in10  @*2, @/2
-  set in10_min   3.0
-  set in10_max   3.6
-
-
-# Temperature inputs
-  ignore temp1
-  ignore temp2
-
-  # PC87366 Internal Temperature
-  # PC87366 Recommended Operating Conditions: 0 - 70C
-  # SC1100  Recommended Operating Conditions: 0 - 85C
-  label temp3       "Temp"
-  label temp3_crit  "Critical"
-  set temp3_min      0
-  set temp3_max     70
-  set temp3_crit    85
-
-
-  ignore temp4
-  ignore temp5
-  ignore temp6
-
-
-# Fan inputs
-  ignore fan1
-  ignore fan2
-  ignore fan3