arpd: fix passing our CFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Mar 2014 17:14:23 +0000 (17:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Mar 2014 17:14:23 +0000 (17:14 +0000)
Our CFLAGS were not properly passed down to the Makefile, fix that.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39936 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/arpd/Makefile

index 5c7bd4e..c0cf110 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arpd
 PKG_VERSION:=0.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_MD5SUM:=e2911fa9de1b92ef50deda1489ae944d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -39,12 +39,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CCOPT="$(TARGET_CFLAGS)" \
-               INCLS="-I. $(TARGET_CPPFLAGS)" \
-               LIBS="$(TARGET_LDFLAGS) -lpcap -ldnet -levent"
-endef
+MAKE_FLAGS += \
+       INCLUDES="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       LIBS="$(TARGET_LDFLAGS) -lpcap -ldnet -levent"
 
 define Package/arpd/install
        $(INSTALL_DIR) $(1)/usr/sbin