Fix/clean several hundred package makefiles
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Aug 2006 21:21:06 +0000 (21:21 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Aug 2006 21:21:06 +0000 (21:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4603 3c298f89-4303-0410-b956-a3cf2f4a3e73

71 files changed:
admin/osiris/Makefile
ipv6/dhcp6/Makefile
ipv6/mrd6/Makefile
libs/axtls/Makefile
libs/bzip2/Makefile
libs/clinkc/Makefile
libs/gmp/Makefile
libs/libcli/Makefile
libs/libiconv/Makefile
libs/libjpeg/Makefile
multimedia/peercast/Makefile
net/aircrack-ng/Makefile
net/aodv-uu/Makefile
net/atftp/Makefile
net/autossh/Makefile
net/bind/Makefile
net/bitchx/Makefile
net/ctorrent/Makefile
net/elinks/Makefile
net/ethtool/Makefile
net/fping/Makefile
net/httping/Makefile
net/iftop/Makefile
net/iptables-snmp/Makefile
net/irssi/Makefile
net/l2tpd/Makefile
net/l2tpns/Makefile
net/miau/Makefile
net/miax/Makefile
net/mini_httpd/Makefile
net/mini_sendmail/Makefile
net/netperf/Makefile
net/netstat-nat/Makefile
net/nfs-server/Makefile
net/ntpclient/Makefile
net/oidentd/Makefile
net/openntpd/Makefile
net/parprouted/Makefile
net/peerguardian/Makefile
net/pptpd/Makefile
net/psybnc/Makefile
net/ptunnel/Makefile
net/reaim/Makefile
net/rp-l2tp/Makefile
net/scanlogd/Makefile
net/shat/Makefile
net/sipp/Makefile
net/srelay/Makefile
net/ssltunnel/Makefile
net/ssmtp/Makefile
net/tinc/Makefile
net/vgp/Makefile
net/vncrepeater/Makefile
net/vnstat/Makefile
net/vrrpd/Makefile
net/yafc/Makefile
utils/bc/Makefile
utils/cifsmount/Makefile
utils/comgt/Makefile
utils/deco/Makefile
utils/gnupg/Makefile
utils/hdparm/Makefile
utils/heyu/Makefile
utils/lcd4linux/Makefile
utils/logrotate/Makefile
utils/macchanger/Makefile
utils/microcom/Makefile
utils/mutt/Makefile
utils/pciutils/Makefile
utils/procmail/Makefile
utils/vim/Makefile

index 24520d8..917134a 100644 (file)
@@ -48,7 +48,6 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               ar=$(TARGET_CROSS)ar \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
index 839afb1..05cf815 100755 (executable)
@@ -55,7 +55,6 @@ define Package/dhcp6-client/conffiles
 /etc/dhcp6/solicit.conf
 endef
 
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/server \
                CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
index 63fe4c9..aab01e4 100644 (file)
@@ -47,8 +47,8 @@ define Build/Compile
                SPACE_OPTIMIZE=yes \
                FULL_STATIC=yes \
                CFLAGS="$(TARGET_CFLAGS) -DNO_INET6_OPTION" \
-               CXX=$(TARGET_CROSS)g++ \
-               CC=$(TARGET_CC) \
+               CXX="$(TARGET_CROSS)g++" \
+               CC="$(TARGET_CC)" \
                STAGING_DIR=$(STAGING_DIR) \
                DESTDIR=$(PKG_INSTALL_DIR) \
                PREFIX=/usr/ \
index f88238d..20e7f1c 100644 (file)
@@ -24,6 +24,7 @@ define Package/libaxtls
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Embedded client/server TLSv1 SSL library
+  DEPENDS:=libgdbm
   DESCRIPTION:=Embedded client/server TLSv1 SSL library.
   URL:=http://sourceforge.net/projects/axtls
 endef
index 0a46e4b..3e4bf53 100644 (file)
@@ -35,7 +35,6 @@ define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                libbz2.a
 endef
index 38102f9..7717d1c 100644 (file)
@@ -32,10 +32,6 @@ define Package/clinkc
   URL:=http://sourceforge.net/projects/clinkc
 endef
 
-define Package/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index a7f910a..1e84b88 100644 (file)
@@ -63,12 +63,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+  $(call Build/Compile/Default, DESTDIR="$(PKG_INSTALL_DIR)" all install)
 endef
 
 define Package/libgmp/install
index 7f944f2..1f2c69c 100755 (executable)
@@ -34,17 +34,8 @@ define Package/libcli
   URL:=http://libcli.sourceforge.net/
 endef
 
-define Build/Configure
-endef
-
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+  $(call Build/Compile/Default, DESTDIR="$(PKG_INSTALL_DIR)" all install)
 endef
 
 define Package/libcli/install
index 49eade9..8476149 100644 (file)
@@ -29,10 +29,6 @@ define Package/libiconv
   URL:=http://www.gnu.org/software/libiconv/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)"
index e136e42..c9f5345 100644 (file)
@@ -59,4 +59,4 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libjpeg.{a,so*}
 endef
 
-$(eval $(call Build/DefaultTargets))
+$(eval $(call BuildPackage,libjpeg))
index 0afa39d..aec2c09 100644 (file)
@@ -42,8 +42,9 @@ define Build/Configure
 $(call Build/Configure/Default,--enable-shared \
                        --disable-static \
                        --with-gnu-ld \
-                       --enable-staticbin, BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+                       --enable-staticbin, \
                $(TARGET_CONFIGURE_OPTS) \
+               BUILD_CC="$(TARGET_CC)" HOSTCC="$(HOSTCC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -nostdinc++ -nodefaultlibs" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -52,11 +53,7 @@ $(call Build/Configure/Default,--enable-shared \
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
 endef
 
 define Package/peercast/install        
index 3744949..f2c8dfb 100644 (file)
@@ -37,7 +37,7 @@ define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+               $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -Wall" \
                prefix="/usr" \
                destdir="$(PKG_INSTALL_DIR)" \
index baa3620..4247d94 100644 (file)
@@ -31,8 +31,8 @@ URL:=http://core.it.uu.se/adhoc/AodvUUImpl
 endef
 
 define Build/Compile
-       $(call Build/Compile/Default,CC="$(TARGET_CC)" \
-KERNEL_DIR="$(LINUX_DIR)/" KCC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
+       $(call Build/Compile/Default, \
+KERNEL_DIR="$(LINUX_DIR)/" KCC="$(TARGET_CC)" \
 CFLAGS="$(TARGET_CFLAGS)" aodvd)
 endef
 
index bc4f4fa..3042711 100644 (file)
@@ -51,10 +51,6 @@ if [ $? -ne 0 ]; then
 fi
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index 391eca7..12fb9a4 100644 (file)
@@ -35,11 +35,10 @@ $(CP) $(PKG_BUILD_DIR)/Makefile.linux $(PKG_BUILD_DIR)/Makefile
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"$(SSH)\\\"\" -D\"VER=\\\"$(PKG_VERSION)\\\"\"" \
-               BINDIR=/usr/bin MANDIR=/usr/man
+$(call Build/Compile/Default, \
+       CFLAGS="$(TARGET_CFLAGS) -Wall -D\"SSH_PATH=\\\"$(SSH)\\\"\" -D\"VER=\\\"$(PKG_VERSION)\\\"\"" \
+       BINDIR=/usr/bin MANDIR=/usr/man \
+)
 endef
 
 define Package/autossh/install
index b0f0d35..808949e 100644 (file)
@@ -110,7 +110,6 @@ define Build/Compile
                gen
        $(MAKE) -C $(PKG_BUILD_DIR) \
        DESTDIR="$(PKG_INSTALL_DIR)" \
-               STAGING_DIR=$(STAGING_DIR) \
                all install
 endef
 
index d64ddea..a355e70 100644 (file)
@@ -33,10 +33,6 @@ define Package/bitchx
   URL:=http://www.bitchx.org
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index b795c45..e5631f5 100755 (executable)
@@ -56,7 +56,7 @@ define Build/Configure
 endef
 
 define Build/Compile   
-       $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+  $(call Build/Compile/Default, DESTDIR=$(PKG_INSTALL_DIR)  install)
 endef
        
 define Package/ctorrent/install        
index dd20436..b1e4970 100644 (file)
@@ -83,11 +83,6 @@ define Build/Configure
        );
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)\
-               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld"
-endef
-
 define Package/elinks/install
        mkdir -p $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/elinks $(1)/usr/bin/
index 25a56a1..3ee4deb 100644 (file)
@@ -30,10 +30,6 @@ define Package/ethtool
   URL:=http://sourceforge.net/projects/gkernel/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index 8f4902b..729dbd9 100644 (file)
@@ -35,10 +35,6 @@ limit it will be considered unreachable.\\\
   URL:=http://www.fping.com
 endef
   
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile   
        $(MAKE) -j1 CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) clean $(PKG_NAME)
        mv $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME)4
index f92015b..a77f2e3 100644 (file)
@@ -32,9 +32,8 @@ transmission across the network also takes time!\\\
   URL:=http://www.vanheusden.com/httping/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) -f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) \
-               CC="$(TARGET_CC)" STAGING_DIR=$(STAGING_DIR)
+define Build/Compile
+  $(call Build/Compile/Default,-f $(PKG_BUILD_DIR)/Makefile$(SSL_ENABLE) STAGING_DIR=$(STAGING_DIR))
 endef
 
 define Package/httping/install 
index 44501c7..93318ce 100644 (file)
@@ -33,17 +33,8 @@ answering the question "why is our ADSL link so slow?".\\\
   URL:=http://www.ex-parrot.com/~pdw/iftop/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
+  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
 endef
 
 define Package/iftop/install   
index dfb243c..eaa6b2f 100644 (file)
@@ -30,16 +30,11 @@ define Package/iptables-snmp
   URL:=http://www.nobiscuit.com/iptables-snmp/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+  $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               all install
+               all install \
+  )
 endef
  
 define Package/iptables-snmp/install   
index 3f815fe..5900d20 100644 (file)
@@ -45,11 +45,6 @@ $(call Build/Configure/Default,--with-perl=no \
 ac_cv_sizeof_off_t=8)
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
-
 define Package/irssi/install   
        mkdir -p $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/fe-text/$(PKG_NAME) $(1)/usr/bin/
index f478e72..1f48380 100644 (file)
@@ -40,10 +40,7 @@ define Package/l2tpd/conffiles
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION"
+  $(call Build/Compile/Default,CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION")
 endef
 
 define Package/l2tpd/install   
index e363df8..323a6dc 100644 (file)
@@ -40,13 +40,7 @@ define Package/l2tpns/conffiles
 endef
        
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               OPTIM="$(TARGET_CFLAGS)" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               STAGING_DIR=$(STAGING_DIR) \
-               all install
+  $(call Build/Compile/Default, LD="$(TARGET_CC)" OPTIM="$(TARGET_CFLAGS)" STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) all install)
 endef
 
 define Package/l2tpns/install  
index b14efc1..3afa9de 100644 (file)
@@ -44,12 +44,7 @@ endef
 
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
+  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
 endef
 
 define Package/miau/install    
index 47ad90e..200dd04 100644 (file)
@@ -32,7 +32,7 @@ keyboard, analog/gsm/isdn modem or bluetooth phones.\\\
  URL:=http://www.eja.it/?l=gpl&testo=miax
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                CC="$(TARGET_CC)" \
                OFLAGS="$(TARGET_CFLAGS)" \
index 8c0c8a7..1640fa7 100644 (file)
@@ -93,7 +93,7 @@ define Build/Compile
        # with MatrixSSL
   ifneq ($(CONFIG_PACKAGE_mini-httpd-matrixssl),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               $(TARGET_CONFIGURE_OPTS) \
                OFLAGS="$(TARGET_CFLAGS)" \
                SSL_DEFS="-DUSE_SSL -DHAVE_MATRIXSSL" \
                SSL_INC="-I$(STAGING_DIR)/usr/include" \
@@ -106,7 +106,7 @@ define Build/Compile
        # with OpenSSL
   ifneq ($(CONFIG_PACKAGE_mini-httpd-openssl),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               $(TARGET_CONFIGURE_OPTS) \
                OFLAGS="$(TARGET_CFLAGS)" \
                SSL_DEFS="-DUSE_SSL -DHAVE_OPENSSL" \
                SSL_INC="-I$(STAGING_DIR)/usr/include" \
@@ -118,7 +118,7 @@ define Build/Compile
        # without SSL
   ifneq ($(CONFIG_PACKAGE_mini-httpd),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               $(TARGET_CONFIGURE_OPTS) \
                OFLAGS="$(TARGET_CFLAGS)" \
                all
   endif
index f2411ed..ac31596 100644 (file)
@@ -34,7 +34,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+               $(TARGET_CONFIGURE_OPTS) \
                OFLAGS="$(TARGET_CFLAGS)" \
                all
 endef
index 2f623f1..134d3d5 100644 (file)
@@ -33,7 +33,7 @@ endef
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
            TARGET_NETPERF_HOME="/etc/netperf.conf" \
-           TARGET_CC=$(TARGET_CROSS)gcc \
+           TARGET_CC="$(TARGET_CROSS)gcc" \
            TARGET_CFLAGS="$(TARGET_CFLAGS)" \
                TARGET_LIBS="" \
                all
index 8128e1a..0164084 100644 (file)
@@ -34,10 +34,6 @@ define Package/netstat-nat
   URL:=http://tweegy.demon.nl/projects/netstat-nat/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile   
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index e9faddb..3132f12 100644 (file)
@@ -30,10 +30,6 @@ define Package/nfs-server
   DESCRIPTION:=User Space NFS server
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef  
-
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)
 endef
index 1984afe..b9ad6db 100644 (file)
@@ -29,9 +29,8 @@ define Package/ntpclient
   URL:=http://doolittle.faludi.com/ntpclient
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" all adjtimex
+define Build/Compile
+  $(call Build/Compile/Default,all adjtimex)
 endef
 
 define Package/ntpclient/install       
index 3a0d0b2..9520375 100755 (executable)
@@ -33,14 +33,11 @@ endef
 
 
 define Build/Configure
-$(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
+  $(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
+  $(call Build/Compile/Default)
        $(STRIP) $(PKG_BUILD_DIR)/src/$(PKG_NAME)
 endef
 
index 57b903a..84375af 100644 (file)
@@ -84,7 +84,6 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DUSE_ADJTIMEX"
-       touch $@
 endef
 
 define Package/openntpd/install        
index 455802a..9fd309a 100644 (file)
@@ -34,9 +34,7 @@ define Package/parprouted
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="" \
-               all
+  $(call Build/Compile/Default,CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="" all)
 endef
 
 define Package/parprouted/install      
index 91a3f50..7315cfc 100755 (executable)
@@ -35,15 +35,6 @@ define Package/peerguardian/conffiles
 /etc/p2p.p2b.p2p
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef  
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               STAGING_DIR=$(STAGING_DIR)
-endef
-
 define Package/peerguardian/install
        install -d -m0755 $(1)/usr/sbin $(1)/etc/init.d
        install -m0755 $(PKG_BUILD_DIR)/peerguardnf $(1)/usr/sbin/
index 1766509..37895b8 100755 (executable)
@@ -61,14 +61,12 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+  $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
-               all install
+               all install \
+  )
 endef
 
 define Package/pptpd/install
index 76b0bc8..4a617a4 100644 (file)
@@ -35,11 +35,11 @@ define Package/psybnc
 endef
 
 define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               HOSTCC="$(HOSTCC)" \
-               all
+  $(call Build/Compile/Default, \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       HOSTCC="$(HOSTCC)" \
+       all \
+  )
 endef
 
 define Package/psybnc/install  
index 119eaa4..a6dbdf9 100644 (file)
@@ -37,9 +37,10 @@ endef
 define Build/Configure
 $(call Build/Configure/Default,--enable-shared \
                --disable-static \
-               --with-gnu-ld, BUILD_CC=$(TARGET_CC) \
-               HOSTCC=$(HOSTCC) \
+               --with-gnu-ld, \
                $(TARGET_CONFIGURE_OPTS) \
+               BUILD_CC="$(TARGET_CC)" \
+               HOSTCC="$(HOSTCC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
@@ -48,11 +49,10 @@ $(call Build/Configure/Default,--enable-shared \
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+  $(call Build/Compile/Default, \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               all install \
+  )
 endef
 
 define Package/ptunnel/install 
index 87e8700..bdf4bc5 100644 (file)
@@ -32,13 +32,11 @@ define Package/reaim
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
+  $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               all install \
+  )
 endef
 
 define Package/reaim/install   
index d482cae..37ea89e 100644 (file)
@@ -45,15 +45,8 @@ define Package/rp-l2tpd-mod-ppp
   TITLE:=a PPP handler for the L2TP daeomon
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
 endef
 
 define Package/rp-l2tpd/install        
index ca255a2..6cd8944 100644 (file)
@@ -44,7 +44,7 @@ endef
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CC=$(TARGET_CC) LD=$(TARGET_CC) CFLAGS="-c $(TARGET_CFLAGS)" \
+               CC="$(TARGET_CC)" LD="$(TARGET_CC)" CFLAGS="-c $(TARGET_CFLAGS)" \
                LDFLAGS= \
                PCAP_H="-I$(STAGING_DIR)/usr/include" \
                NIDS_H="-I$(STAGING_DIR)/usr/include" \
index ce55ff9..ec7bdf4 100644 (file)
@@ -33,7 +33,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DVERSION=\\\"$(PKG_VERSION)\\\" -DDROP_NETBIOS"
 endef
 
index 3009355..ad04470 100644 (file)
@@ -34,15 +34,14 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               CC_linux=$(TARGET_CC) \
-               CPP_linux=$(TARGET_CC) \
-               CCLINK_linux=$(TARGET_CC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CC_linux="$(TARGET_CC)" \
+               CPP_linux="$(TARGET_CC)" \
+               CCLINK_linux="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS_linux="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -nostdinc++" \
                LFLAGS_linux="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                LIBS="-luClibc++ -lc -lm -lgcc -lpthread -ldl -lncurses" \
-               STAGING_DIR=$(STAGING_DIR) \
                all
 endef
 
index db1b2e2..595f378 100644 (file)
@@ -39,11 +39,6 @@ define Build/Configure
 $(call Build/Configure/Default,--disable-thread)
 endef
 
-define Build/Compile
-$(call Build/Compile/Default, CC=$(TARGET_CC) \
-               all)
-endef
-
 define Package/srelay/install  
        install -m0755 -d $(1)/usr/bin
        install -m0755 -d $(1)/etc/init.d
index c653cf1..6fb5017 100644 (file)
@@ -32,7 +32,7 @@ define Package/ssltunnel
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,,BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC))
+  $(call Build/Configure/Default,,BUILD_CC="$(TARGET_CC)" HOSTCC="$(HOSTCC)")
 endef
 
 define Build/Compile
index a6e591a..8215a54 100644 (file)
@@ -34,10 +34,7 @@ define Package/ssmtp
   URL:=http://packages.debian.org/stable/mail/ssmtp
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-       
+
 define Build/Compile
 $(call Build/Compile/Default,all)
 endef
index 7e4f3b1..a5105a0 100644 (file)
@@ -39,7 +39,7 @@ $(call Build/Configure/Default,--with-kernel=$(LINUX_DIR) \
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,CC=$(TARGET_CC) \
+$(call Build/Compile/Default,CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install)
index 34381a0..43cdfa7 100755 (executable)
@@ -33,10 +33,6 @@ define Package/vgp
   URL:=http://vgpd.freaknet.org/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
 $(call Build/Compile/Default,DESTDIR=$(PKG_INSTALL_DIR) install)
 endef
index e2601de..ead836f 100644 (file)
@@ -41,7 +41,7 @@ define Package/vncrepeater/
 endef
 
 define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
+$(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                repeater)
index 7350b16..86e5414 100644 (file)
@@ -33,10 +33,6 @@ define Package/vnstat
   URL:=http://humdi.net/vnstat/
 endef
 
-define Build/Compile
-$(call Build/Compile/Default)
-endef
-
 define Package/vnstat/install  
        install -d -m0755 $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/vnstat $(1)/usr/bin/
index 17344c0..854776b 100644 (file)
@@ -38,7 +38,7 @@ define Package/vrrpd/conffiles
 endef
 
 define Build/Compile   
-$(call Build/Compile/Default,CC="$(TARGET_CC)" \
+$(call Build/Compile/Default, \
                DBG_OPT="" \
                MAIN_OPT="$(TARGET_CFLAGS)" \
                vrrpd)
index 4fa243d..92cc5ae 100644 (file)
@@ -35,13 +35,6 @@ define Build/Configure
 $(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
-
 define Package/yafc/install
        install -m0755 -d $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
index 8613c68..0d7bbf6 100644 (file)
@@ -39,17 +39,6 @@ define Package/dc
   URL:=http://www.gnu.org/software/bc/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
-
 define Package/bc/install
        install -m0755 -d $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME)/$(PKG_NAME) $(1)/usr/bin/$(PKG_NAME)
index 147e09b..9cc4c3a 100644 (file)
@@ -28,9 +28,6 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
 
-define Build/Configure
-endef
-
 define Build/Compile
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mount.cifs mount.cifs.c
 endef
index 28874be..0df02f4 100644 (file)
@@ -41,10 +41,7 @@ define Build/Prepare
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               gcom
+  $(call Build/Compile/Default,gcom)
 endef
        
 define Package/comgt/install
index 78a92db..abd9a31 100644 (file)
@@ -30,10 +30,6 @@ define Package/deco
   URL:=http://deco.sourceforge.net/
 endef
   
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
 endef
index 4ea1dc2..43b6035 100644 (file)
@@ -76,11 +76,6 @@ define Build/Configure
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
-
 define Package/gnupg/install
        install -d -m0755 $(1)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/g10/gpg $(1)/usr/bin/
index 36ced21..9328b07 100644 (file)
@@ -36,11 +36,6 @@ endef
 define Build/Configure
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
-
 define Package/hdparm/install
        install -d -m0755 $(1)/usr/sbin
        install -m0755 $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
index 37d528d..b451d79 100644 (file)
@@ -31,10 +31,8 @@ define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
-               CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ"
+define Build/Compile
+  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ")
 endef
 
 define Package/heyu/install    
index 5eb9e15..2af009b 100644 (file)
@@ -65,9 +65,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" LD="$(TARGET_CROSS)ld" \
-               CFLAGS="$(TARGET_CFLAGS) -Wall"
+  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS) -Wall")
 endef
 
 define Package/lcd4linux/install
index 27eddda..4548f29 100644 (file)
@@ -41,10 +41,11 @@ define Package/logrotate/conffiles
 endef
 
 define Build/Compile
-       make -C ${PKG_BUILD_DIR} \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               CC="$(TARGET_CC)" logrotate
+  $(call Build/Compile/Default, \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+       logrotate \
+  )
 endef
 
 define Package/logrotate/install       
index 24b5a86..8522248 100755 (executable)
@@ -29,10 +29,6 @@ of network interfaces.
   URL:=http://www.alobbs.com/macchanger
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile   
        $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
 endef
index ab21865..646c9e5 100644 (file)
@@ -42,10 +42,6 @@ define Build/Configure
        sed 's~gcc~$$(CC)~' $(PKG_BUILD_DIR)/Makefile.tmp > $(PKG_BUILD_DIR)/Makefile
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)"
-endef
-
 define Package/microcom/install
        install -d -m0755 $(1)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/microcom $(1)/usr/bin
index 11494de..f54b739 100644 (file)
@@ -41,11 +41,6 @@ $(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/. \
                ac_cv_sizeof_long=4)
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC)
-endef
-
 define Package/mutt/install
        mkdir -p $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
index 7b12360..724f2b0 100644 (file)
@@ -37,8 +37,7 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+  $(call Build/Compile/Default, CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME))
 endef
 
 define Package/pciutils/install
index efe9ec6..ac232a9 100644 (file)
@@ -33,7 +33,7 @@ endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src -f ../Makefile.openwrt  \
-               CC=$(TARGET_CC)
+               $(TARGET_CONFIGURE_OPTS)
 endef
 
 define Package/procmail/install
index f5e0d4d..aa6f526 100644 (file)
@@ -42,10 +42,6 @@ $(call Build/Configure/Default,--enable-min-features \
                        ac_cv_sizeof_int=4)
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)")
-endef
-
 define Package/vim/install     
        mkdir -p $(1)/usr/bin
        mkdir -p $(1)//usr/share/vim