Add qolyester, thanks to Khaldoun Al Agha !
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Dec 2007 11:30:48 +0000 (11:30 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Dec 2007 11:30:48 +0000 (11:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9725 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/qolyester/Makefile [new file with mode: 0644]

diff --git a/net/qolyester/Makefile b/net/qolyester/Makefile
new file mode 100644 (file)
index 0000000..7bec65e
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=qolyester
+PKG_VERSION:=20070910
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://qolsr.lri.fr/code/
+PKG_MD5SUM:=9c1cf1868e085f47e135a86945d93ce0
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/qolyester
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread
+  TITLE:=OLSR implementation with QoS
+  URL:=http://qolsr.lri.fr/code/
+endef
+
+define Package/qolyester/description
+       This is an implementation from scratch of the OLSR protocol.
+       It is written in the C++ programming language and its goals
+       are modularity, efficiency and conformance to RFC 3626 (OLSR).
+endef
+
+# uses GNU configure
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/qolyester/install       
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/qolsrd $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,qolyester))