[package] elfutils: package libelf and libdw, update to 0.152
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Jul 2011 20:22:19 +0000 (20:22 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Jul 2011 20:22:19 +0000 (20:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27499 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/elfutils/Makefile
libs/elfutils/patches/001-elfutils-portability.patch
libs/elfutils/patches/003-no_warnings_as_errors.patch
libs/elfutils/patches/005-only_libdw_libelf.patch [new file with mode: 0644]

index afb3502..6bf7029 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,41 +7,53 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elfutils
-PKG_VERSION:=0.150
+PKG_VERSION:=0.152
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
-PKG_MD5SUM:=3dcfb28fa339090a1d29a9e148cce469
+PKG_MD5SUM:=39739ed58a0fa1862eff8735f111fe5c
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
-define Package/elfutils
+define Package/elfutils/Default
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=$(INTL_DEPENDS)
-  TITLE:=ELF utilities
+  TITLE:=ELF manipulation libraries
   URL:=https://fedorahosted.org/elfutils/
 endef
 
-CONFIGURE_OPTS += \
-       --disable-generic \
+define Package/libelf
+  $(call Package/elfutils/Default)
+  TITLE+= (libelf)
+endef
 
-MAKE_PATH:=./libelf
+define Package/libdw
+  $(call Package/elfutils/Default)
+  TITLE+= (libdw)
+endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/libelf/libelf.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libelf/libelf.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/libdw/libdw.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libelf/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libelf/libelf.so* $(1)/usr/lib/
 endef
 
-define Package/elfutils/install
+define Package/libdw/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libelf/libelf.so.* $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/libdw/libdw.so* $(1)/usr/lib/
 endef
 
-$(eval $(call BuildPackage,elfutils))
+$(eval $(call BuildPackage,libdw))
+$(eval $(call BuildPackage,libelf))
index be10154..c7b30d9 100644 (file)
@@ -82,7 +82,7 @@
  libebl_i386.so: $(cpu_i386)
 --- a/ChangeLog
 +++ b/ChangeLog
-@@ -7,6 +7,10 @@
+@@ -13,6 +13,10 @@
  
        * configure.ac (LOCALEDIR, DATADIRNAME): Removed.
  
@@ -93,7 +93,7 @@
  2009-09-21  Ulrich Drepper  <drepper@redhat.com>
  
        * configure.ac: Update for more modern autoconf.
-@@ -15,6 +19,10 @@
+@@ -21,6 +25,10 @@
  
        * configure.ac (zip_LIBS): Check for liblzma too.
  
  2009-04-19  Roland McGrath  <roland@redhat.com>
  
        * configure.ac (eu_version): Round down here, not in version.h macros.
-@@ -26,6 +34,8 @@
+@@ -32,6 +40,8 @@
  
  2009-01-23  Roland McGrath  <roland@redhat.com>
  
        * configure.ac (zlib check): Check for gzdirect, need zlib >= 1.2.2.3.
  
        * configure.ac (__thread check): Use AC_LINK_IFELSE, in case of
-@@ -106,6 +116,10 @@
+@@ -112,6 +122,10 @@
        * configure.ac: Add dummy automake conditional to get dependencies
        for non-generic linker right.  See src/Makefile.am.
  
  2005-11-18  Roland McGrath  <roland@redhat.com>
  
        * Makefile.am (DISTCHECK_CONFIGURE_FLAGS): New variable.
-@@ -153,6 +167,17 @@
+@@ -159,6 +173,17 @@
        * Makefile.am (all_SUBDIRS): Add libdwfl.
        * configure.ac: Write libdwfl/Makefile.
  
  LEXLIB
  LEX_OUTPUT_ROOT
  LEX
-@@ -3858,6 +3860,130 @@ if test "x$ac_cv_c99" != xyes; then :
+@@ -3856,6 +3858,130 @@ if test "x$ac_cv_c99" != xyes; then :
    as_fn_error $? "gcc with C99 support required" "$LINENO" 5
  fi
  
  { $as_echo "$as_me:${as_lineno-$LINENO}: checking for __thread support" >&5
  $as_echo_n "checking for __thread support... " >&6; }
  if test "${ac_cv_tls+set}" = set; then :
-@@ -3894,7 +4020,11 @@ fi
+@@ -3892,7 +4018,11 @@ fi
  { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_tls" >&5
  $as_echo "$ac_cv_tls" >&6; }
  if test "x$ac_cv_tls" != xyes; then :
  fi
  
  # Check whether --enable-largefile was given.
-@@ -4880,7 +5010,7 @@ ac_config_files="$ac_config_files versio
+@@ -4878,7 +5008,7 @@ ac_config_files="$ac_config_files versio
  
  # 1.234<whatever> -> 1234<whatever>
  case "$PACKAGE_VERSION" in
  *)               as_fn_error $? "confused by version number '$PACKAGE_VERSION'" "$LINENO" 5 ;;
  esac
  case "$eu_version" in
-@@ -4909,7 +5039,7 @@ case "$eu_version" in
+@@ -4907,7 +5037,7 @@ case "$eu_version" in
  esac
  
  # Round up to the next release API (x.y) version.
  # This file is a shell script that caches the results of configure
 --- a/configure.ac
 +++ b/configure.ac
-@@ -73,6 +73,54 @@ CFLAGS="$old_CFLAGS"])
+@@ -70,6 +70,54 @@ CFLAGS="$old_CFLAGS"])
  AS_IF([test "x$ac_cv_c99" != xyes],
        AC_MSG_ERROR([gcc with C99 support required]))
  
  AC_CACHE_CHECK([for __thread support], ac_cv_tls, [dnl
  # Use the same flags that we use for our DSOs, so the test is representative.
  # Some old compiler/linker/libc combinations fail some ways and not others.
-@@ -88,7 +136,10 @@ static __thread int a; int foo (int b) {
+@@ -85,7 +133,10 @@ static __thread int a; int foo (int b) {
  CFLAGS="$save_CFLAGS"
  LDFLAGS="$save_LDFLAGS"])
  AS_IF([test "x$ac_cv_tls" != xyes],
  
  dnl This test must come as early as possible after the compiler configuration
  dnl tests, because the choice of the file model can (in principle) affect
-@@ -251,7 +302,7 @@ AC_SUBST([eu_version])
+@@ -248,7 +299,7 @@ AC_SUBST([eu_version])
  
  # 1.234<whatever> -> 1234<whatever>
  case "$PACKAGE_VERSION" in
  *)               AC_MSG_ERROR([confused by version number '$PACKAGE_VERSION']) ;;
  esac
  case "$eu_version" in
-@@ -280,6 +331,6 @@ case "$eu_version" in
+@@ -277,6 +328,6 @@ case "$eu_version" in
  esac
  
  # Round up to the next release API (x.y) version.
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libasm/ChangeLog
 +++ b/libasm/ChangeLog
-@@ -67,6 +67,11 @@
+@@ -71,6 +71,11 @@
        * asm_error.c: Add new error ASM_E_IOERROR.
        * libasmP.h: Add ASM_E_IOERROR definition.
  
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libdwfl/ChangeLog
 +++ b/libdwfl/ChangeLog
-@@ -1331,6 +1331,11 @@
+@@ -1366,6 +1366,11 @@
  
  2005-07-21  Roland McGrath  <roland@redhat.com>
  
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libelf/ChangeLog
 +++ b/libelf/ChangeLog
-@@ -666,6 +666,11 @@
+@@ -671,6 +671,11 @@
  
        * elf.h: Update from glibc.
  
          break;
 --- a/src/ChangeLog
 +++ b/src/ChangeLog
-@@ -225,8 +225,16 @@
+@@ -260,8 +260,16 @@
        * readelf.c (attr_callback): Use print_block only when we don't use
        print_ops.
  
        * ar.c (do_oper_extract): Use pathconf instead of statfs.
  
  2009-08-01  Ulrich Drepper  <drepper@redhat.com>
-@@ -390,6 +398,8 @@
+@@ -425,6 +433,8 @@
        * readelf.c (print_debug_frame_section): Use t instead of j formats
        for ptrdiff_t OFFSET.
  
  2009-01-21  Ulrich Drepper  <drepper@redhat.com>
  
        * elflint.c (check_program_header): Fix typo in .eh_frame_hdr section
-@@ -573,6 +583,11 @@
+@@ -608,6 +618,11 @@
        that matches its PT_LOAD's p_flags &~ PF_W.  On sparc, PF_X really
        is valid in RELRO.
  
  2008-02-29  Roland McGrath  <roland@redhat.com>
  
        * readelf.c (print_attributes): Add a cast.
-@@ -824,6 +839,8 @@
+@@ -859,6 +874,8 @@
  
        * readelf.c (hex_dump): Fix rounding error in whitespace calculation.
  
  2007-10-15  Roland McGrath  <roland@redhat.com>
  
        * make-debug-archive.in: New file.
-@@ -1263,6 +1280,10 @@
+@@ -1298,6 +1315,10 @@
        * elflint.c (valid_e_machine): Add EM_ALPHA.
        Reported by Christian Aichinger <Greek0@gmx.net>.
  
  2006-08-08  Ulrich Drepper  <drepper@redhat.com>
  
        * elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
-@@ -1339,6 +1360,10 @@
+@@ -1374,6 +1395,10 @@
        * Makefile.am: Add hacks to create dependency files for non-generic
        linker.
  
  2006-06-12  Ulrich Drepper  <drepper@redhat.com>
  
        * ldgeneric.c (ld_generic_generate_sections): Don't create .interp
-@@ -1687,6 +1712,11 @@
+@@ -1722,6 +1747,11 @@
        * readelf.c (print_debug_loc_section): Fix indentation for larger
        address size.
  
  
  /* Name and version of program.  */
  static void print_version (FILE *stream, struct argp_state *state);
-@@ -301,8 +307,18 @@ process_file (const char *fname)
+@@ -311,8 +317,18 @@ process_file (const char *fname)
  
        /* If we have to preserve the timestamp, we need it in the
         format utimes() understands.  */
      }
  
    /* Open the file.  */
-@@ -1747,7 +1763,7 @@ handle_elf (int fd, Elf *elf, const char
+@@ -1809,7 +1825,7 @@ while computing checksum for debug infor
    /* If requested, preserve the timestamp.  */
    if (tvp != NULL)
      {
        {
          error (0, errno, gettext ("\
  cannot set access and modification date of '%s'"),
-@@ -1804,7 +1820,7 @@ handle_ar (int fd, Elf *elf, const char
+@@ -1866,7 +1882,7 @@ handle_ar (int fd, Elf *elf, const char
  
    if (tvp != NULL)
      {
  cannot set access and modification date of '%s'"), fname);
 --- a/tests/ChangeLog
 +++ b/tests/ChangeLog
-@@ -154,6 +154,8 @@
+@@ -205,6 +205,8 @@
  
  2008-01-21  Roland McGrath  <roland@redhat.com>
  
        * testfile45.S.bz2: Add tests for cltq, cqto.
        * testfile45.expect.bz2: Adjust.
  
-@@ -862,6 +864,11 @@
+@@ -913,6 +915,11 @@
        * Makefile.am (TESTS): Add run-elflint-test.sh.
        (EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
  
index 2f3aa1a..b56a2dd 100644 (file)
        $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
        $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
        $(am__append_1) $(am__append_2)
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -191,7 +191,7 @@ zip_LIBS = @zip_LIBS@
+ INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
+       -I$(srcdir)/../libelf
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1) -fpic
+--- a/libasm/Makefile.in
++++ b/libasm/Makefile.in
+@@ -240,7 +240,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+       -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
+       -I$(top_srcdir)/libdw
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1)
+--- a/libcpu/Makefile.in
++++ b/libcpu/Makefile.in
+@@ -209,7 +209,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+       -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+       -I$(srcdir)/../libdw -I$(srcdir)/../libasm
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1) -fpic -fdollars-in-identifiers
+--- a/libdw/Makefile.in
++++ b/libdw/Makefile.in
+@@ -284,7 +284,7 @@ zip_LIBS = @zip_LIBS@
+ INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
+       -I$(srcdir)/../libelf
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1) $(am__append_2)
+--- a/libdwfl/Makefile.in
++++ b/libdwfl/Makefile.in
+@@ -275,7 +275,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+       -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+       -I$(srcdir)/../libdw
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1)
+--- a/libebl/Makefile.in
++++ b/libebl/Makefile.in
+@@ -236,7 +236,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+       -I$(srcdir)/../libelf -I$(srcdir)/../libdw \
+       -I$(srcdir)/../libasm
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1) -fpic
+--- a/tests/Makefile.in
++++ b/tests/Makefile.in
+@@ -463,7 +463,7 @@ top_srcdir = @top_srcdir@
+ zip_LIBS = @zip_LIBS@
+ INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. $(am__append_2)
+ AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
+-      $($(*F)_no_Werror),,-Werror) $(if \
++      $($(*F)_no_Werror),,) $(if \
+       $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
+       $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
+       $(am__append_1)
diff --git a/libs/elfutils/patches/005-only_libdw_libelf.patch b/libs/elfutils/patches/005-only_libdw_libelf.patch
new file mode 100644 (file)
index 0000000..93d1dbe
--- /dev/null
@@ -0,0 +1,27 @@
+diff -urN elfutils-0.152/Makefile.am elfutils-0.152.new/Makefile.am
+--- elfutils-0.152/Makefile.am 2011-07-06 20:22:31.111366384 +0200
++++ elfutils-0.152.new/Makefile.am     2011-07-06 20:32:46.081366237 +0200
+@@ -30,8 +30,8 @@
+ pkginclude_HEADERS = version.h
+ # Add doc back when we have some real content.
+-SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
+-        src po
++SUBDIRS = config m4 lib libelf libebl libdwfl libdw
++
+ EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION
+diff -urN elfutils-0.152/Makefile.in elfutils-0.152.new/Makefile.in
+--- elfutils-0.152/Makefile.in 2011-07-06 20:22:31.111366384 +0200
++++ elfutils-0.152.new/Makefile.in     2011-07-06 20:32:54.211366235 +0200
+@@ -248,8 +248,7 @@
+ pkginclude_HEADERS = version.h
+ # Add doc back when we have some real content.
+-SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
+-        src po
++SUBDIRS = config m4 lib libelf libebl libdwfl libdw
+ EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION