packages/pulseaudio: run as a pulse/pulse user/group, enable deprecated oss output...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:21 +0000 (22:16 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 22:16:21 +0000 (22:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29077 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/pulseaudio/Makefile
sound/pulseaudio/files/pulseaudio.init

index afaeaf2..266c5ba 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
@@ -94,9 +94,9 @@ define Package/pulseaudio-profiles
 endef
 
 CONFIGURE_ARGS += \
-       --with-system-user=root \
-       --with-system-group=root \
-       --with-access-group=root \
+       --with-system-user=pulse \
+       --with-system-group=pulse \
+       --with-access-group=audio \
        --with-database=simple \
        --enable-alsa \
        --disable-hal \
@@ -104,7 +104,7 @@ CONFIGURE_ARGS += \
        --disable-tcpwrap \
        --disable-nls \
        --disable-manpages \
-       --disable-oss-output \
+       --enable-oss-output \
        --disable-oss-wrapper \
        --disable-samplerate \
        --disable-per-user-esound-socket \
@@ -124,7 +124,7 @@ endif
 ifeq ($(BUILD_VARIANT),noavahi)
 CONFIGURE_ARGS += \
        --disable-avahi \
-       --disable-dbus  
+       --disable-dbus
 endif
 
 CONFIGURE_VARS += \
index b5bf94d..0ae8f1b 100644 (file)
@@ -1,12 +1,27 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2011 OpenWrt.org
+
 START=65
 
+SERVICE_USE_PID=1
+SERVICE_PID_FILE=/var/run/pulse/pid
+
 start() {
-       mkdir -p /tmp/lib/pulse
-       /usr/bin/pulseaudio --daemonize --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1
+       user_exists pulse 51 || user_add pulse 51
+       group_exists pulse 51 || group_add pulse 51
+       [ -d /var/run/pulse ] || {
+               mkdir -m 0755 -p /var/run/pulse
+               chmod 0750 /var/run/pulse
+               chown pulse:pulse /var/run/pulse
+       }
+       [ -d /var/lib/pulse ] || {
+               mkdir -m 0755 -p /var/lib/pulse
+               chmod 0750 /var/lib/pulse
+               chown pulse:pulse /var/lib/pulse
+       }
+       service_start /usr/bin/pulseaudio --daemonize --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1
 }
 
 stop() {
-       killall pulseaudio
+       service_stop /usr/bin/pulseaudio
 }