packages: udpxy: update to new version and add init script
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2012 11:58:33 +0000 (11:58 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2012 11:58:33 +0000 (11:58 +0000)
This patch updates version to 1.0.21-2.

Signed-off-by: Nerijus Baliƫnas <nerijus@users.sourceforge.net>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30583 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/udpxy/Makefile
net/udpxy/files/udpxy.init [new file with mode: 0644]

index ac94094..71e1332 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udpxy
-PKG_REV:=1.0
-PKG_TAG:=Chipmunk-20
+PKG_REV:=1.0.21
+PKG_TAG:=2
 PKG_VERSION:=$(PKG_REV)-$(PKG_TAG)
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME).$(PKG_REV)-$(patsubst Chipmunk-%,Chipmunk-BLD%,$(PKG_TAG)).tgz
+PKG_SOURCE:=$(PKG_NAME).$(PKG_REV)-$(patsubst %,%-prod,$(PKG_TAG)).tgz
 PKG_SOURCE_URL:=@SF/udpxy
-PKG_MD5SUM:=da0a587cfc81fb4a501b07ed84237469
+PKG_MD5SUM:=d969fc34604b3abcc8ef62510967f2b0
 
 PKG_INSTALL:=1
 
@@ -42,6 +42,8 @@ MAKE_FLAGS += \
        INSTALLROOT="$(PKG_INSTALL_DIR)/usr"
 
 define Package/udpxy/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/udpxy.init $(1)/etc/init.d/udpxy
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udpxy $(1)/usr/bin/
        ln -sf udpxy $(1)/usr/bin/udpxrec
diff --git a/net/udpxy/files/udpxy.init b/net/udpxy/files/udpxy.init
new file mode 100644 (file)
index 0000000..41d7481
--- /dev/null
@@ -0,0 +1,27 @@
+#!/bin/sh /etc/rc.common
+
+# To open multicast traffic, add the following rule at the end of
+# /etc/config/firewall file:
+#
+# config 'rule'
+#     option 'target' 'ACCEPT'
+#     option '_name' 'multicast'
+#     option 'src' 'wan'
+#     option 'proto' 'all'
+#     option 'dest_ip' '224.0.0.0/4'
+
+START=99
+STOP=10
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
+OPTIONS="-T -S -p 4022"
+
+start() {
+       service_start /usr/bin/udpxy $OPTIONS
+}
+
+stop() {
+       service_stop /usr/bin/udpxy
+}