[package] fix pcapsipdump compilation failure (#6983)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Mar 2010 11:03:25 +0000 (11:03 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Mar 2010 11:03:25 +0000 (11:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@20576 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/pcapsipdump/Makefile
net/pcapsipdump/patches/002-elif_else_replacement.patch [new file with mode: 0644]

index 8c6369b..adb057c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcapsipdump
 PKG_VERSION:=0.1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/psipdump
@@ -30,7 +30,7 @@ define Package/pcapsipdump/description
         fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
         (even if there is thousands of concurrect SIP sessions).
 endef
-       
+
 define Build/Compile
        $(TARGET_CONFIGURE_OPTS) \
                $(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/net/pcapsipdump/patches/002-elif_else_replacement.patch b/net/pcapsipdump/patches/002-elif_else_replacement.patch
new file mode 100644 (file)
index 0000000..bb217b7
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN pcapsipdump-0.1.4/pcapsipdump.h pcapsipdump-0.1.4.new/pcapsipdump.h
+--- pcapsipdump-0.1.4/pcapsipdump.h    2007-05-11 20:40:49.000000000 +0200
++++ pcapsipdump-0.1.4.new/pcapsipdump.h        2010-03-29 09:52:20.000000000 +0200
+@@ -35,7 +35,7 @@
+ #elif defined (__BIG_ENDIAN)
+       uint8_t version:4,
+               ihl:4;
+-#elif
++#else
+ #error Endian not defined
+ #endif
+       uint8_t tos;