lttng-tools: fix build and add md5sum
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Feb 2014 15:04:05 +0000 (15:04 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Feb 2014 15:04:05 +0000 (15:04 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39553 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/lttng-tools/Makefile
devel/lttng-tools/patches/001-uclibc_sync_file_ranges.patch

index 7b4ed02..371a5b9 100644 (file)
@@ -13,7 +13,8 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)
-PKG_MD5SUM:=
+PKG_MD5SUM:=cfc35db9eb2d4ae09a65c006a70204f6
+PKG_FIXUP:=autoreconf
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index fcaaa3e..e3507b6 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Samuel Martin <s.martin49@gmail.com>
  src/common/compat/fcntl.h |    5 +++++
  2 files changed, 6 insertions(+), 1 deletion(-)
 
-diff --git a/configure.ac b/configure.ac
-index 5808c79..065b9cf 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xyes"], [
+@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xye
        )
  ])
  AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [test "x$lttng_ust_ctl_found" = xyes])
@@ -25,13 +23,11 @@ index 5808c79..065b9cf 100644
  
  # check for dlopen
  AC_CHECK_LIB([dl], [dlopen],
-@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],[
+@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],
  ])
  
  AS_ECHO()
 -
-diff --git a/src/common/compat/compat-fcntl.c b/src/common/compat/compat-fcntl.c
-index 5a1c757..7ff63a3 100644
 --- a/src/common/compat/compat-fcntl.c
 +++ b/src/common/compat/compat-fcntl.c
 @@ -23,7 +23,11 @@
@@ -46,6 +42,3 @@ index 5a1c757..7ff63a3 100644
  }
  
  #endif /* __linux__ */
--- 
-1.8.0.3
-