Add karma
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2007 11:41:30 +0000 (11:41 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2007 11:41:30 +0000 (11:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9315 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/karma/Makefile [new file with mode: 0644]

diff --git a/net/karma/Makefile b/net/karma/Makefile
new file mode 100644 (file)
index 0000000..80f2fdd
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=karma
+PKG_VERSION:=20060124
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://theta44.org/software/
+PKG_MD5SUM:=e9d4ccbda89b4b1cd70eefb1db339d0a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/karma
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+kmod-madwifi-karma +ruby +libpcap +libncurses
+  TITLE:=set of tools for assessing the security of wireless clients
+  URL:=http://theta44.org/karma/index.html
+endef
+
+define Package/karma/description
+  KARMA is a set of tools for assessing the security of wireless clients
+  at multiple layers. Wireless sniffing tools discover clients and their
+  preferred/trusted networks by passively listening for 802.11 Probe Request
+  frames.
+endef
+
+define Package/karma/conffiles
+/etc/karma-lan.xml
+/etc/karma-scan.xml
+/etc/karma.xml
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/src/ \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDLIBS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lpcap -lncurses"
+endef
+
+define Package/karma/install   
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/bin/karma $(1)/usr/sbin/karma-ruby
+       $(CP) $(PKG_BUILD_DIR)/src/karma $(1)/usr/sbin/karma
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_BUILD_DIR)/etc/* $(1)/etc/
+endef
+
+$(eval $(call BuildPackage,karma))