tor: add geoip package
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Feb 2011 18:23:41 +0000 (18:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Feb 2011 18:23:41 +0000 (18:23 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25347 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tor/Makefile

index 2799b53..495fae0 100644 (file)
@@ -19,15 +19,13 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/tor
+define Package/tor/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libevent +libopenssl +libpthread
-  TITLE:=An anonymous Internet communication system
   URL:=http://www.torproject.org/
 endef
 
-define Package/tor/description
+define Package/tor/Default/description
  Tor is a toolset for a wide range of organizations and people that want to
  improve their safety and security on the Internet. Using Tor can help you
  anonymize web browsing and publishing, instant messaging, IRC, SSH, and
@@ -35,6 +33,18 @@ define Package/tor/description
  new applications with built-in anonymity, safety, and privacy features.
 endef
 
+define Package/tor
+$(call Package/tor/Default)
+  TITLE:=An anonymous Internet communication system
+  DEPENDS:=+libevent +libopenssl +libpthread
+endef
+
+define Package/tor-geoip
+$(call Package/tor/Default)
+  TITLE:=GeoIP db for tor
+  DEPENDS:=+tor
+endef
+
 define Package/tor/conffiles
 /etc/tor/torrc
 endef
@@ -94,4 +104,10 @@ define Package/tor/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
 endef
 
+define Package/tor-geoip/install
+       $(INSTALL_DIR) $(1)/usr/share/tor
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/tor/geoip $(1)/usr/share/tor
+endef
+
 $(eval $(call BuildPackage,tor))
+$(eval $(call BuildPackage,tor-geoip))