ssmtp: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Nov 2014 13:44:50 +0000 (13:44 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Nov 2014 13:44:50 +0000 (13:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@43226 3c298f89-4303-0410-b956-a3cf2f4a3e73

mail/ssmtp/Makefile [deleted file]

diff --git a/mail/ssmtp/Makefile b/mail/ssmtp/Makefile
deleted file mode 100644 (file)
index 0240ae0..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (C) 2007-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ssmtp
-PKG_VERSION:=2.64
-PKG_RELEASE:=4
-
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.bz2
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp
-PKG_MD5SUM:=65b4e0df4934a6cd08c506cabcbe584f
-
-include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS += $(TARGET_CPPFLAGS)
-
-define Package/ssmtp
-  SECTION:=mail
-  CATEGORY:=Mail
-  DEPENDS:=+libopenssl
-  TITLE:=A minimal and secure mail sender
-  URL:=http://packages.debian.org/ssmtp
-endef
-
-define Package/ssmtp/description
- A secure, effective and simple way of getting mail off a system to your
- mail hub. It contains no suid-binaries or other dangerous things - no
- mail spool to poke around in, and no daemons running in the background.
- mail is simply forwarded to the configured mailhost. Extremely easy
- configuration.
-endef
-
-define Package/ssmtp/conffiles
-/etc/ssmtp/ssmtp.conf
-/etc/ssmtp/revaliases
-endef
-
-CONFIGURE_VARS += \
-       LIBS="$(TARGET_LDFLAGS) -lcrypto -lssl"
-
-CONFIGURE_ARGS += \
-       --enable-ssl
-
-define Package/ssmtp/install
-       $(INSTALL_DIR) $(1)/etc/ssmtp
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ssmtp.conf $(1)/etc/ssmtp/
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/revaliases $(1)/etc/ssmtp/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ssmtp $(1)/usr/sbin/
-endef
-
-define Package/ssmtp/postinst
-#!/bin/sh
-ln -sf ssmtp $${IPKG_INSTROOT}/usr/sbin/sendmail
-endef
-
-$(eval $(call BuildPackage,ssmtp))