poco: ensure we pass our CFLAGS and LDFLAGS
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:37 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:37 +0000 (00:57 +0000)
Use the CFLAGS32, CXXFLAGS32 and LINKFLAGS32 to pass our custom CFLAGS.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39824 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/poco/Makefile

index 2b75e1f..d93a990 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=poco
 PKG_VERSION:=1.3.6p2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/poco/sources/poco-1.3.6
@@ -42,6 +42,11 @@ CONFIGURE_ARGS += \
        --no-sharedmemory \
        --no-wstring
 
+MAKE_FLAGS += \
+       CXXFLAGS32="$(TARGET_CXXFLAGS)" \
+       CFLAGS32="$(TARGET_CFLAGS)" \
+       LINKFLAGS32="$(TARGET_LDFLAGS)"
+
 define Package/poco/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libPoco{Foundation,XML,Net,Util}.so* $(1)/usr/lib/