packages: add pyload (a fast, lightweight and full featured download manager)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Dec 2011 12:14:27 +0000 (12:14 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Dec 2011 12:14:27 +0000 (12:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29400 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/pyload/Makefile [new file with mode: 0644]
net/pyload/files/pyload.init [new file with mode: 0644]

diff --git a/net/pyload/Makefile b/net/pyload/Makefile
new file mode 100644 (file)
index 0000000..4a5d9e4
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pyload
+PKG_VERSION:=0.4.8
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-src-v$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://download.pyload.org/
+PKG_MD5SUM:=5bcf8411ef9e48ef6e9ade55bc697900
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/pyload
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+python +pyopenssl +python-curl +python-crypto +python-django \
+       +python-expat +python-imaging-library +python-sqlite3 +js \
+       +tesseract +unrar
+  TITLE:=A fast, lightweight and full featured download manager
+  URL:=http://pyload.org
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/pyload/install
+       $(INSTALL_DIR) $(1)/usr/share/python
+       $(CP) $(PKG_BUILD_DIR)/pyload $(1)/usr/share/python/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/pyload.init $(1)/etc/init.d/pyload
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(LN) ../share/python/pyload/pyLoadCore.py $(1)/usr/bin/pyload
+endef
+
+$(eval $(call BuildPackage,pyload))
diff --git a/net/pyload/files/pyload.init b/net/pyload/files/pyload.init
new file mode 100644 (file)
index 0000000..cd0e270
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=94
+
+start() {
+       /usr/bin/python /usr/share/python/pyload/pyLoadCore.py --configdir=/etc/pyload --daemon
+}
+
+stop() {
+       /usr/bin/python /usr/share/python/pyload/pyLoadCore.py --configdir=/etc/pyload --quit
+}