packages/subversion: force use of LFS and 64-bit off_t (really closes: #9287)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Nov 2011 13:51:55 +0000 (13:51 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 Nov 2011 13:51:55 +0000 (13:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28765 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/subversion/Makefile

index 9eb8041..690f10d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
 PKG_VERSION:=1.6.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads
@@ -73,6 +73,9 @@ define Package/subversion-server/conffiles
 /etc/config/subversion
 endef
 
+TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 CONFIGURE_ARGS += \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \