[packages] btpd: add autoreconf fixup to prevent openssl removal related build failures
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Feb 2011 08:09:53 +0000 (08:09 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Feb 2011 08:09:53 +0000 (08:09 +0000)
 * re-drop libopenssl dependency
 * fix description's long lines

git-svn-id: svn://svn.openwrt.org/openwrt/packages@25339 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/btpd/Makefile

index 803546a..14830d6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/downloads/btpd/btpd
 PKG_MD5SUM:=fe042aae8d7c515ecd855673d1c2b33e
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -22,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/btpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread +libopenssl
+  DEPENDS:=+libpthread
   SUBMENU:=BitTorrent
   TITLE:=btpd - BitTorrent Protocol Daemon
   URL:=https://github.com/btpd/btpd/wiki/
@@ -31,9 +32,12 @@ endef
 define Package/btpd/description
        BTPD is a bittorrent client consisting of a daemon and client commands,
        which can be used to read and/or manipulate the daemon state.
-       The daemon is capable of running several torrents simultaneously and only uses one tcp port.
-       It's fairly low on resource usage and should be perfect for file distribution sites.
-       Efficient downloads and ease of use makes this client a good choice for the casual user as well.
+       The daemon is capable of running several torrents simultaneously and
+       only uses one tcp port.
+       It's fairly low on resource usage and should be perfect for file
+       distribution sites.
+       Efficient downloads and ease of use makes this client a good choice for
+       the casual user as well.
 endef
 
 define Package/btpd/conffiles