fix some more postinst brokenness
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Aug 2006 22:05:22 +0000 (22:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Aug 2006 22:05:22 +0000 (22:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4645 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/atftp/Makefile
net/tor/Makefile

index 3042711..0e45338 100644 (file)
@@ -42,12 +42,12 @@ endef
 
 define Package/atftpd/postinst
 #!/bin/sh
-grep -q '^tftp[[:space:]]*69/tcp' ${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $? -ne 0 ]; then
-       echo "tftp            69/tcp" >>${IPKG_INSTROOT}/etc/services
-       echo "tftp            69/udp" >>${IPKG_INSTROOT}/etc/services
-       echo "tftp-mcast    1758/tcp" >>${IPKG_INSTROOT}/etc/services
-       echo "tftp-mcast    1758/udp" >>${IPKG_INSTROOT}/etc/services
+grep -q '^tftp[[:space:]]*69/tcp' $${IPKG_INSTROOT}/etc/services 2>/dev/null
+if [ $$? -ne 0 ]; then
+       echo "tftp            69/tcp" >>$${IPKG_INSTROOT}/etc/services
+       echo "tftp            69/udp" >>$${IPKG_INSTROOT}/etc/services
+       echo "tftp-mcast    1758/tcp" >>$${IPKG_INSTROOT}/etc/services
+       echo "tftp-mcast    1758/udp" >>$${IPKG_INSTROOT}/etc/services
 fi
 endef
 
index a825319..7a6012a 100644 (file)
@@ -50,10 +50,10 @@ id=52
 
 # do not change below
 # # check if we are on real system
-# if [ -z "${IPKG_INSTROOT}" ]; then
+# if [ -z "$${IPKG_INSTROOT}" ]; then
 #         # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $5 }'`
-        if [ "$rootfs" = "squashfs" ]; then
+        rootfs=`mount |awk '/root/ { print $$5 }'`
+        if [ "$$rootfs" = "squashfs" ]; then
                 if [ -h /etc/group ]; then
                         rm /etc/group
                         cp /rom/etc/group /etc/group
@@ -66,14 +66,14 @@ id=52
 fi
 
 echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $name to /etc/group"
-        echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+        echo "adding group $$name to /etc/group"
+        echo "$${name}:x:$${id}:" >> ${IPKG_INSTROOT}/etc/group
 fi
 
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
+if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
         echo "adding user $name to /etc/passwd"
-        echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
+        echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
 fi
 endef