bumped up to the latest FS git commit (84d029e4b92c5161aca2c6317f3ff1087c60d52a)
authormazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 10:51:09 +0000 (10:51 +0000)
committermazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 10:51:09 +0000 (10:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28720 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeswitch/Makefile
net/freeswitch/patches/009-src-mod-codecs-mod_silk-Makefile.patch [new file with mode: 0644]

index 78d9eb7..5cc4aa6 100644 (file)
@@ -17,7 +17,7 @@ PKG_RELEASE:=1
 #
 # The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
 #
-PKG_REV:=50328a663452006b78e79e2004c20d111ffb263f
+PKG_REV:=84d029e4b92c5161aca2c6317f3ff1087c60d52a
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
@@ -714,7 +714,7 @@ $(eval $(call BuildPlugin,fsk,Bell-202 1200-baud FSK decoder,mod_fsk,,))
 $(eval $(call BuildPlugin,fsv,Video,mod_fsv,,))
 $(eval $(call BuildPlugin,g723-1,G.723.1 codec,mod_g723_1,,))
 $(eval $(call BuildPlugin,g729,G.729 codec,mod_g729,,))
-$(eval $(call BuildPlugin,gsmopen,Short Message Service (SMS),mod_gsmopen,spandsp,+alsa-lib +gsmlib))
+$(eval $(call BuildPlugin,gsmopen,Short Message Service (SMS),mod_gsmopen,spandsp,+alsa-lib +libgsm))
 $(eval $(call BuildPlugin,h26x,H26X linear codec,mod_h26x,,))
 $(eval $(call BuildPlugin,h323,h323 endpoint,mod_h323,,@BROKEN)) # missing header files (other packages needed)
 $(eval $(call BuildPlugin,hash,API for manipulating a hash table,mod_hash,,))
diff --git a/net/freeswitch/patches/009-src-mod-codecs-mod_silk-Makefile.patch b/net/freeswitch/patches/009-src-mod-codecs-mod_silk-Makefile.patch
new file mode 100644 (file)
index 0000000..53c9705
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/src/mod/codecs/mod_silk/Makefile
++++ b/src/mod/codecs/mod_silk/Makefile
+@@ -1,4 +1,5 @@
+ BASE=../../../..
++include $(BASE)/build/openwrt_rules.mk
+ SILK_DIR=$(switch_srcdir)/libs/silk
+ SILK_BUILDDIR=$(switch_builddir)/libs/silk
+ LOCAL_CFLAGS=-I$(SILK_DIR)/src  -I$(SILK_DIR)/interface
+@@ -7,5 +8,5 @@ LOCAL_LIBADD=$(SILK_LA)
+ include $(BASE)/build/modmake.rules
+ $(SILK_LA): $(SILK_DIR)/.update       
+-      cd $(SILK_BUILDDIR) && ./configure --disable-shared && make clean && $(MAKE)
++      cd $(SILK_BUILDDIR) && ./configure --host=$(GNU_TARGET_NAME) --disable-shared && make clean && $(MAKE)
+       $(TOUCH_TARGET)