[packages] net/rtorrent: fix compilation errors on brcm-2.4
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Jun 2009 01:59:31 +0000 (01:59 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Jun 2009 01:59:31 +0000 (01:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16596 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rtorrent/Makefile
net/rtorrent/patches/901-upstream_rt_triple.patch [new file with mode: 0644]
net/rtorrent/patches/902-gcc_3.4.6_wstring_fix.patch [new file with mode: 0644]

index 9db3354..2269c59 100644 (file)
@@ -12,7 +12,7 @@ PKG_NAME:=rtorrent
 
 PKG_REV:=1094
 PKG_VERSION:=0.8.4_r$(PKG_REV)
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
diff --git a/net/rtorrent/patches/901-upstream_rt_triple.patch b/net/rtorrent/patches/901-upstream_rt_triple.patch
new file mode 100644 (file)
index 0000000..d773acb
--- /dev/null
@@ -0,0 +1,24 @@
+Upstream patch from: http://libtorrent.rakshasa.no/ticket/1271
+
+Fix the following gcc-3.4.6 ICE:
+
+In file included from ./../rpc/command_map.h:45,
+                 from ./../rpc/parse_commands.h:43,
+                 from dht_manager.cc:46:
+./../rpc/command.h: In function `rpc::target_type rpc::get_target_left(const rpc::target_type&)':
+./../rpc/command.h:153: internal compiler error: Segmentation fault
+
+--- a/src/rpc/command.h
++++ b/src/rpc/command.h
+@@ -73,10 +73,8 @@ struct rt_triple : private std::pair<T1,
+   rt_triple(const T1& a, const T2& b, const T3& c) :
+     base_type(a, b), third(c) {}
+-  template <typename U1, typename U2>
+-  rt_triple(const std::pair<U1, U2>& b) : base_type(b), third() {}
++  rt_triple(const base_type& b) : base_type(b), third() {}
+-  template <typename U1, typename U2, typename U3>
+   rt_triple(const rt_triple& src) :
+     base_type(src.first, src.second), third(src.third) {}
+ };
diff --git a/net/rtorrent/patches/902-gcc_3.4.6_wstring_fix.patch b/net/rtorrent/patches/902-gcc_3.4.6_wstring_fix.patch
new file mode 100644 (file)
index 0000000..c8096e7
--- /dev/null
@@ -0,0 +1,15 @@
+--- rtorrent-0.8.4_r1094/src/display/window_file_list.h        2009-06-18 02:53:53.000000000 -0700
++++ rtorrent-0.8.4_r1094/src/display/window_file_list.h        2009-06-19 00:52:30.000000000 -0700
+@@ -39,6 +39,12 @@
+ #include "window.h"
++
++// two-bit hack for gcc 3.4.6
++namespace std {
++      typedef basic_string<wchar_t> wstring;
++}
++
+ namespace ui {
+   class ElementFileList;
+ }