python-gnome-desktop2: turn the libwnck dependency into a conditional dependency
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Apr 2010 15:58:53 +0000 (15:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Apr 2010 15:58:53 +0000 (15:58 +0000)
this prevents it from being added as a build dependency for the whole package,
as the other part of this package can be built without wnck
fixes builds with the directfb display feature flag

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21091 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/python-gnome-desktop2/Makefile

index addb409..1162c32 100644 (file)
@@ -44,7 +44,7 @@ define Package/python-rsvg
 endef
 
 define Package/python-wnck
-       $(call Package/python-gnome-desktop/Default,libwnck,+libwnck)
+       $(call Package/python-gnome-desktop/Default,libwnck,+PACKAGE_python-wnck:libwnck)
 endef
 
 define Build/Configure