[packages] luacurl: add package
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 7 Feb 2014 15:10:33 +0000 (15:10 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 7 Feb 2014 15:10:33 +0000 (15:10 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39523 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/luacurl/Makefile [new file with mode: 0644]

diff --git a/lang/luacurl/Makefile b/lang/luacurl/Makefile
new file mode 100644 (file)
index 0000000..1b20c72
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luacurl
+PKG_VERSION:=20140207
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/msva/lua-curl.git
+PKG_SOURCE_VERSION:=047ac31ecd18c2526eed84e349e5016de2633fac
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/luacurl
+  SUBMENU:=Lua
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Lua-cURL
+  URL:=http://msva.github.io/lua-curl/
+  DEPENDS:=+liblua +libcurl
+endef
+
+define Package/luacurl/description
+ Lua-cURL is aiming for a full-fledged libcurl binding (easy/multi/share
+ interface) to the functionality of Lua
+endef
+
+CMAKE_OPTIONS += \
+       -DUSE_LUA=ON
+
+define Package/luacurl/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cURL.so $(1)/usr/lib/lua/
+endef
+
+$(eval $(call BuildPackage,luacurl))