Update to the latest GIT commit and added the new application mod_http_cache to downl...
authormazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Oct 2011 17:12:26 +0000 (17:12 +0000)
committermazilo <mazilo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Oct 2011 17:12:26 +0000 (17:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28407 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/freeswitch/Makefile
net/freeswitch/files/etc.minimal/autoload_configs/modules.conf.xml
net/freeswitch/files/etc.packages/http_cache/autoload_configs/http_cache.conf.xml [new file with mode: 0644]
net/freeswitch/patches/001-build-modules_conf_in.patch

index d040de5..34dcee3 100644 (file)
@@ -16,7 +16,7 @@ PKG_RELEASE:=1
 #
 # The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
 #
-PKG_REV:=decb286114a685ea7920030f60f733c3fe34358c
+PKG_REV:=7b0d878925e4703278362cc5c11abff54f82ad54
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
@@ -77,6 +77,7 @@ FS_MOD_AVAILABLE:= \
        h26x \
        h323 \
        hash \
+       http_cache \
        ilbc \
        java \
        json-cdr \
@@ -304,6 +305,7 @@ $(call Package/$(PKG_NAME)/Default)
                +$(PKG_NAME)-mod-g723-1 \
                +$(PKG_NAME)-mod-g729 \
                +$(PKG_NAME)-mod-hash \
+               +$(PKG_NAME)-mod-http-cache \
                +$(PKG_NAME)-mod-ilbc \
                +$(PKG_NAME)-mod-local-stream \
                +$(PKG_NAME)-mod-lua \
@@ -728,6 +730,7 @@ $(eval $(call BuildPlugin,gsmopen,Short Message Service (SMS),mod_gsmopen,spands
 $(eval $(call BuildPlugin,h26x,H26X linear codec,mod_h26x,,))
 $(eval $(call BuildPlugin,h323,h323 endpoint,mod_h323,,@BROKEN)) # missing header files (other packages needed)
 $(eval $(call BuildPlugin,hash,API for manipulating a hash table,mod_hash,,))
+$(eval $(call BuildPlugin,http_cache,HTTP GET with caching,mod_http_cache,,))
 $(eval $(call BuildPlugin,ilbc,ILBC codec,mod_ilbc,,))
 $(eval $(call BuildPlugin,java,Java language interface,mod_java,,@BROKEN)) # needs java
 $(eval $(call BuildPlugin,json-cdr,JSon-CDR interface,mod_json_cdr,,))
index e27dce8..a94b32e 100644 (file)
@@ -46,6 +46,7 @@
 
     <!-- Applications -->
     <!-- <load module="mod_blacklist"/> -->
+    <!-- <load module="mod_http_cache"/> -->
     <load module="mod_commands"/>
     <load module="mod_conference"/>
     <load module="mod_db"/>
diff --git a/net/freeswitch/files/etc.packages/http_cache/autoload_configs/http_cache.conf.xml b/net/freeswitch/files/etc.packages/http_cache/autoload_configs/http_cache.conf.xml
new file mode 100644 (file)
index 0000000..4150d64
--- /dev/null
@@ -0,0 +1,8 @@
+<configuration name="http_cache.conf" description="HTTP GET cache">
+  <settings>
+    <param name="max-urls" value="10000"/>
+    <param name="location" value="$${base_dir}/http_cache"/>
+    <param name="default-max-age" value="86400"/>
+  </settings>
+</configuration>
+
index a7b1956..838d5a4 100644 (file)
@@ -1,9 +1,10 @@
 --- a/build/modules.conf.in
 +++ b/build/modules.conf.in
-@@ -40,10 +40,13 @@ applications/mod_valet_parking
+@@ -41,10 +41,14 @@ applications/mod_valet_parking
  #applications/mod_ladspa
  #applications/mod_mongo
  applications/mod_sms
++#applications/mod_http_cache
 +#applications/mod_mp4
 +#applications/mod_protovm
  codecs/mod_g723_1
@@ -14,7 +15,7 @@
  #codecs/mod_codec2
  codecs/mod_g729
  #codecs/mod_com_g729
-@@ -61,6 +64,7 @@ dialplans/mod_dialplan_xml
+@@ -62,6 +66,7 @@ dialplans/mod_dialplan_xml
  dialplans/mod_dialplan_asterisk
  #directories/mod_ldap
  #endpoints/mod_dingaling
@@ -22,7 +23,7 @@
  #endpoints/mod_portaudio
  endpoints/mod_sofia
  endpoints/mod_loopback
-@@ -81,6 +85,7 @@ endpoints/mod_loopback
+@@ -82,6 +87,7 @@ endpoints/mod_loopback
  #event_handlers/mod_event_multicast
  event_handlers/mod_event_socket
  #event_handlers/mod_event_zmq