packages: remove dependency on obsolete LINUX_2_4 symbol
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Nov 2011 18:07:06 +0000 (18:07 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Nov 2011 18:07:06 +0000 (18:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28960 3c298f89-4303-0410-b956-a3cf2f4a3e73

48 files changed:
devel/ksymoops/Makefile
ipv6/dibbler/Makefile
libs/avahi/Makefile
libs/boost/Makefile
libs/keynote/Makefile
libs/libaio/Makefile
libs/libnetfilter-conntrack/Makefile
libs/libnetfilter-log/Makefile
libs/libnetfilter-queue/Makefile
libs/libnfnetlink/Makefile
libs/libtorrent/Makefile
libs/serdisplib/Makefile
libs/sysfsutils/Makefile
multimedia/fswebcam/Makefile
multimedia/gst-plugins-bad/Makefile
multimedia/gst-plugins-base/Makefile
multimedia/gst-plugins-good/Makefile
multimedia/gst-plugins-ugly/Makefile
multimedia/gstreamer/Makefile
multimedia/qc-usb/Makefile
net/batman-adv/Makefile
net/et131x/Makefile
net/haproxy/Makefile
net/ipsec-tools/Makefile
net/iputils/Makefile
net/isakmpd/Makefile
net/linuxigd/Makefile
net/lldpd/Makefile
net/nbd/Makefile
net/openswan/Makefile
net/speedtouch-usb-firmware/Makefile
net/squid/Makefile
net/usbip/Makefile
net/xtables-addons/Makefile
utils/btrfs-progs/Makefile
utils/collectd/Makefile
utils/cryptsetup/Makefile
utils/cwiid/Makefile
utils/gadgetfs-test/Makefile
utils/i2c-tools/Makefile
utils/lirc/Makefile
utils/mdadm/Makefile
utils/mtd-utils/Makefile
utils/pcmciautils/Makefile
utils/psplash/Makefile
utils/sierra-pcmcia/Makefile
utils/stress/Makefile
utils/testusb/Makefile

index 446fbc2..b883bed 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ksymoops
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!LINUX_2_4 @mips||mipsel||m68k||i386
+  DEPENDS:=@mips||mipsel||m68k||i386
   TITLE:=Interpret oops of the kernel
   URL:=http://www.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/
   MENU:=1
index 6a2a443..7241bfb 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dibbler/Default
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libstdcpp @!LINUX_2_4 +libpthread
+  DEPENDS:=+libstdcpp +libpthread
   TITLE:=Dibbler, a portable DHCPv6 implementation
   URL:=http://klub.com.pl/dhcpv6/
 endef
index 5372492..a8d287d 100644 (file)
@@ -57,7 +57,7 @@ define Package/libavahi-dbus
   $(call Package/avahi/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libdaemon +libpthread +libgdbm +dbus @!LINUX_2_4
+  DEPENDS:=+libdaemon +libpthread +libgdbm +dbus
   TITLE+= (library) (dbus)
   VARIANT:=dbus
 endef
index 1d6c2fb..dff08a2 100644 (file)
@@ -44,7 +44,7 @@ define Package/boost/Default
   CATEGORY:=Libraries
   TITLE:=Boost C++ source libraries
   URL:=http://www.boost.org
-  DEPENDS:=+libstdcpp @!LINUX_2_4
+  DEPENDS:=+libstdcpp
 endef
 
 define Package/boost/Default/description
index e25f002..fdca388 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/keynote
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=@!LINUX_2_4 +libopenssl
+  DEPENDS:=+libopenssl
   TITLE:=Simple and flexible trust-management system
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
index 147db8e..dc467ea 100644 (file)
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libaio
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@!LINUX_2_4
   TITLE:=Linux kernel AIO interface access library
   URL:=http://lse.sourceforge.net/io/aio.html
 endef
index 690b9ac..620d13f 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libnetfilter-conntrack
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@!LINUX_2_4 +libnfnetlink +kmod-nf-conntrack-netlink
+  DEPENDS:=+libnfnetlink +kmod-nf-conntrack-netlink
   TITLE:=API to the in-kernel connection tracking state table
   URL:=http://www.netfilter.org/projects/libnetfilter_conntrack/
 endef
index 0936941..75125c2 100644 (file)
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libnetfilter-log
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@!LINUX_2_4 +libnfnetlink +kmod-nfnetlink-log
+  DEPENDS:=+libnfnetlink +kmod-nfnetlink-log
   TITLE:=API to packets logged by the kernel packet filter
   URL:=http://www.netfilter.org/projects/libnetfilter_log/
 endef
index d10a799..abe62d4 100644 (file)
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libnetfilter-queue
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@!LINUX_2_4 +libnfnetlink +kmod-nfnetlink-queue
+  DEPENDS:=+libnfnetlink +kmod-nfnetlink-queue
   TITLE:=API to packets queued by the kernel packet filter
   URL:=http://www.netfilter.org/projects/libnetfilter_queue/
 endef
index 85d3c7c..3029b37 100644 (file)
@@ -27,7 +27,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libnfnetlink
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@!LINUX_2_4
   TITLE:=A low-level library for netfilter related kernel/userspace communication
   URL:=http://netfilter.org/projects/libnfnetlink/
 endef
index 6a3d783..40f0c39 100644 (file)
@@ -26,7 +26,7 @@ define Package/libtorrent
   CATEGORY:=Libraries
   TITLE:=Rakshasa's BitTorrent library
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libopenssl +libsigcxx @!LINUX_2_4
+  DEPENDS:=+libopenssl +libsigcxx
   MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
index 4d9833e..f9a6b44 100644 (file)
@@ -21,7 +21,6 @@ define Package/serdisplib
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=A display control library
-  DEPENDS:=@!LINUX_2_4
   URL:=http://serdisplib.sourceforge.net/
 endef
 
index cfad23c..4dc7dc1 100644 (file)
@@ -25,7 +25,6 @@ define Package/libsysfs
   SECTION:=libs
   CATEGORY:=Libraries
   SUBMENU:=Filesystem
-  DEPENDS:=@!LINUX_2_4
   TITLE:=Sysfs library
   URL:=http://linux-diag.sourceforge.net/Sysfsutils.html
 endef
@@ -34,7 +33,7 @@ define Package/sysfsutils
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Filesystem
-  DEPENDS:=@!LINUX_2_4 +libsysfs
+  DEPENDS:=+libsysfs
   TITLE:=System Utilities Based on Sysfs
   URL:=http://linux-diag.sourceforge.net/Sysfsutils.html
 endef
index cfd9201..8c6167c 100644 (file)
@@ -24,7 +24,7 @@ define Package/fswebcam
   CATEGORY:=Multimedia
   TITLE:=fswebcam
   URL:=http://www.sanslogic.co.uk/fswebcam/
-  DEPENDS:= @!LINUX_2_4 +libgd
+  DEPENDS:=+libgd
 endef
 
 define Package/fswebcam/description
index 5cef2d9..c792ff1 100644 (file)
@@ -28,7 +28,6 @@ define Package/gstreamer/Default
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default
index db2b3d3..7916c1c 100644 (file)
@@ -45,7 +45,6 @@ define Package/gstreamer/Default
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default
index f382dd7..080dd80 100644 (file)
@@ -27,7 +27,6 @@ define Package/gstreamer/Default
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default
index 0fb8bdb..1ebdd7e 100644 (file)
@@ -33,7 +33,6 @@ define Package/gstreamer/Default
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default
index 6462e9e..e7b0651 100644 (file)
@@ -28,7 +28,6 @@ define Package/gstreamer/Default
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default
index 6f6f0bd..07248dc 100644 (file)
@@ -38,7 +38,7 @@ define KernelPackage/video-quickcam
 $(call Package/qc-usb/Default)
   SUBMENU:=Video Support
   TITLE:=QuickCam Express USB webcam support
-  DEPENDS:=@USB_SUPPORT @LINUX_2_4||LINUX_2_6_25||LINUX_2_6_27||LINUX_2_6_28 +kmod-usb-core +kmod-video-core
+  DEPENDS:=@USB_SUPPORT @LINUX_2_6_25||LINUX_2_6_27||LINUX_2_6_28 +kmod-usb-core +kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/quickcam.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,quickcam)
 endef
index 345f64e..93fc391 100644 (file)
@@ -28,7 +28,7 @@ define KernelPackage/batman-adv
   URL:=http://www.open-mesh.org/
   MAINTAINER:=Marek Lindner <lindner_marek@yahoo.de>
   SUBMENU:=Network Support
-  DEPENDS:=@!LINUX_2_4 +kmod-lib-crc16
+  DEPENDS:=+kmod-lib-crc16
   TITLE:=B.A.T.M.A.N. Adv
   FILES:=$(PKG_BUILD_DIR)/batman-adv.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,batman-adv)
index 8b3f91d..25b6414 100644 (file)
@@ -29,7 +29,7 @@ define KernelPackage/et131x
   KCONFIG:= \
        CONFIG_ET131X=m \
        CONFIG_ET131X_DEBUG=n
-  DEPENDS:=@!LINUX_2_4 @PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT
   AUTOLOAD:=$(call AutoLoad,70,et131x)
 endef
 
index 3c71739..205d6d3 100644 (file)
@@ -37,7 +37,7 @@ define Package/haproxy/description
 endef
 
 define Build/Compile
-       $(MAKE) TARGET=$(if $(CONFIG_LINUX_2_4),linux24,linux26) -C $(PKG_BUILD_DIR) \
+       $(MAKE) TARGET=linux26 -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
index 34d0c0a..50b3332 100644 (file)
@@ -25,7 +25,7 @@ define Package/ipsec-tools
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=VPN
-  DEPENDS:=@!LINUX_2_4 +libopenssl +kmod-ipsec
+  DEPENDS:=+libopenssl +kmod-ipsec
   TITLE:=IPsec management tools
   URL:=http://ipsec-tools.sourceforge.net/
 endef
index 712076b..331751d 100644 (file)
@@ -25,7 +25,6 @@ define Package/iputils/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.skbuff.net/iputils
-  DEPENDS:= @!LINUX_2_4
 endef
 
 
index af8f4cf..9301e9a 100644 (file)
@@ -24,7 +24,7 @@ define Package/isakmpd
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=VPN
-  DEPENDS:=@!LINUX_2_4 +libopenssl +keynote +libgmp
+  DEPENDS:=+libopenssl +keynote +libgmp
   TITLE:=IPsec management tools
   URL:=http://isakmpd.sourceforge.net/
 endef
index 6fc5c15..745a7f4 100644 (file)
@@ -25,7 +25,7 @@ define Package/linuxigd
   CATEGORY:=Network
   TITLE:=UPnP daemon
   SUBMENU:=Firewall
-  DEPENDS:=+libiptc +libupnp +libpthread @!LINUX_2_4
+  DEPENDS:=+libiptc +libupnp +libpthread
   URL:=http://linux-igd.sourceforge.net/
 endef
 
index a4e6241..83103e5 100644 (file)
@@ -22,7 +22,6 @@ define Package/lldpd
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol damon
-  DEPENDS:=@!LINUX_2_4
   URL:=https://trac.luffy.cx/lldpd/
 endef
 
index 15f0059..ea63cc8 100644 (file)
@@ -29,7 +29,7 @@ define Package/nbd
   CATEGORY:=Network
   TITLE:=Network Block Device utilities
   URL:=http://nbd.sourceforge.net
-  DEPENDS:=@!LINUX_2_4 +kmod-nbd
+  DEPENDS:=+kmod-nbd
 endef
 
 define Package/nbd/description
index 1a33dd1..222f2a8 100644 (file)
@@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openswan/Default
   TITLE:=Openswan
   URL:=http://www.openswan.org/
-  DEPENDS:=@!LINUX_2_4
 endef
 
 define Package/openswan/Default/description
index b4e641f..f2a4afd 100644 (file)
@@ -24,7 +24,7 @@ define Package/speedtouch-usb-firmware
   SECTION:=net
   CATEGORY:=Network
   TITLE:=SpeedTouch 330 ADSL USB firmware
-  DEPENDS:=+kmod-usb-atm +kmod-usb-atm-speedtouch @!LINUX_2_4
+  DEPENDS:=+kmod-usb-atm +kmod-usb-atm-speedtouch
   PKGARCH:=all
 endef
 
index f0b2790..f96b696 100644 (file)
@@ -27,7 +27,7 @@ endef
 define Package/squid
   $(call Package/squid/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpthread @!LINUX_2_4
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=full-featured Web proxy cache
 endef
 
index 7748ca7..b62a88e 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/usbip/Common
   TITLE:=USB-over-IP
   URL:=http://usbip.sourceforge.net/
-  DEPENDS:=@!LINUX_2_4 @USB_SUPPORT
+  DEPENDS:=@USB_SUPPORT
   MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
 endef
 
index b9deedd..512e4a2 100644 (file)
@@ -71,7 +71,7 @@ define BuildTemplate
     $$(call Package/xtables-addons)
     CATEGORY:=Network
     TITLE:=$(2) iptables extension
-    DEPENDS:= @!LINUX_2_4 iptables $(if $(4),+kmod-ipt-$(1))
+    DEPENDS:=iptables $(if $(4),+kmod-ipt-$(1))
   endef
 
   define Package/iptables-mod-$(1)/install
@@ -90,7 +90,7 @@ define BuildTemplate
   define KernelPackage/ipt-$(1)
     SUBMENU:=Netfilter Extensions
     TITLE:=$(2) netfilter module
-    DEPENDS:= @!LINUX_2_4 kmod-ipt-core $(6)
+    DEPENDS:=kmod-ipt-core $(6)
     FILES:=$(foreach mod,$(4),$(PKG_BUILD_DIR)/extensions/$(mod).$(LINUX_KMOD_SUFFIX))
     AUTOLOAD:=$(call AutoLoad,$(5),$(notdir $(4)))
   endef
index 4e173d7..4ee46c1 100644 (file)
@@ -24,7 +24,7 @@ define Package/btrfs-progs
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Filesystem
-  DEPENDS:=@!LINUX_2_4 +libuuid +zlib
+  DEPENDS:=+libuuid +zlib
   TITLE:=Btrfs filesystems utilities
   URL:=http://btrfs.wiki.kernel.org/
 endef
index 5390d88..de08a89 100644 (file)
@@ -268,7 +268,7 @@ $(eval $(call BuildPlugin,exec,process exec input,exec,))
 $(eval $(call BuildPlugin,filecount,file count input,filecount,))
 $(eval $(call BuildPlugin,fscache,file-system based caching framework input,fscache,))
 $(eval $(call BuildPlugin,interface,network interfaces input,interface,))
-$(eval $(call BuildPlugin,iptables,iptables status input,iptables,+PACKAGE_collectd-mod-iptables:iptables @(!LINUX_2_4||BROKEN)))
+$(eval $(call BuildPlugin,iptables,iptables status input,iptables,+PACKAGE_collectd-mod-iptables:iptables))
 $(eval $(call BuildPlugin,irq,interrupt usage input,irq,))
 $(eval $(call BuildPlugin,load,system load input,load,))
 $(eval $(call BuildPlugin,logfile,log files output,logfile,))
@@ -276,7 +276,7 @@ $(eval $(call BuildPlugin,madwifi,MadWifi status input,madwifi,))
 $(eval $(call BuildPlugin,mysql,MySQL status input,mysql,+PACKAGE_collectd-mod-mysql:libmysqlclient))
 $(eval $(call BuildPlugin,memory,physical memory usage input,memory,))
 $(eval $(call BuildPlugin,modbus,read variables through libmodbus,modbus,+PACKAGE_collectd-mod-modbus:libmodbus))
-$(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip @(!LINUX_2_4||BROKEN)))
+$(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip))
 $(eval $(call BuildPlugin,network,network input/output,network))
 $(eval $(call BuildPlugin,nginx,nginx status input,nginx,+PACKAGE_collectd-mod-nginx:libcurl))
 $(eval $(call BuildPlugin,ntpd,NTP daemon status input,ntpd,))
index cf7c002..1973af5 100644 (file)
@@ -28,7 +28,7 @@ $(call Package/cryptsetup/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Cryptsetup
-  DEPENDS:=@!LINUX_2_4 +libblkid +libuuid +libpopt +lvm2 +libgcrypt
+  DEPENDS:=+libblkid +libuuid +libpopt +lvm2 +libgcrypt
 endef
 
 define Package/cryptsetup/description
index 370d4f3..195b58b 100644 (file)
@@ -23,7 +23,6 @@ $(call include_mk, python-package.mk)
 define Package/cwiid/Default
   TITLE:=Linux Nintendo Wiimote interface
   URL:=http://abstrakraft.org/cwiid/
-  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/libcwiid
index ae6b021..3dfc298 100644 (file)
@@ -24,7 +24,7 @@ define Package/gadgetfs-test
   CATEGORY:=Utilities
   SUBMENU:=Filesystem
   TITLE:=Test program for gadgetfs
-  DEPENDS:=@DEVEL @!LINUX_2_4 +libpthread
+  DEPENDS:=@DEVEL +libpthread
   URL:=http://linux-usb.org/gadget
 endef
 
index d2119a5..d67d8bb 100644 (file)
@@ -25,7 +25,6 @@ define Package/i2c-tools
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=I2C tools for Linux
-  DEPENDS:=@!LINUX_2_4
   URL:=http://www.lm-sensors.org/wiki/I2CTools
 endef
 
index 5b71d15..6afe4a4 100644 (file)
@@ -30,7 +30,6 @@ endef
 define  Package/lirc
     $(call Package/lirc/Default)
     TITLE:=LIRC - Linux Infrared Remote Control
-    DEPENDS:=@!LINUX_2_4
     MENU:=1
 endef
 
index 1488f7a..c33c8cd 100644 (file)
@@ -24,7 +24,6 @@ define Package/mdadm
   CATEGORY:=Utilities
   TITLE:=A tool for managing Soft RAID under Linux
   URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
-  DEPENDS:=@!LINUX_2_4
   MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
index f61c4bb..9c72046 100644 (file)
@@ -103,11 +103,6 @@ MAKE_FLAGS += \
        LDLIBS+="$(LIBGCC_S)" \
        WITHOUT_XATTR=1
 
-ifeq ($(CONFIG_LINUX_2_4),y)
-MAKE_FLAGS += \
-       SUBDIRS=""
-endif
-
 define PartInstall
 define Package/mtd-utils-$(subst _,-,$(1))/install
        $(INSTALL_DIR) \
index d2e2720..e0bfacf 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/pcmciautils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libsysfs @!LINUX_2_4 @PCMCIA_SUPPORT
+  DEPENDS:=+libsysfs @PCMCIA_SUPPORT
   TITLE:=PCMCIA Utilities
   URL:=http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html
 endef
index 2825603..de8228d 100644 (file)
@@ -27,7 +27,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/psplash
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!LINUX_2_4
   TITLE:=A boot splash screen
   URL:=http://projects.o-hand.com/psplash
 endef
index e6c1e16..3b25b18 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/pcmcia-serial-sierra
   SUBMENU:=Other modules
   TITLE:=Sierra AirCard PCMCIA support
-  DEPENDS:=kmod-pcmcia-serial @!LINUX_2_4
+  DEPENDS:=kmod-pcmcia-serial
   URL:=http://www.sierrawireless.com/faq/ShowFAQ.aspx?ID=118
 endef
 
index 735b0a1..12203fa 100644 (file)
@@ -22,7 +22,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/stress
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!LINUX_2_4
   TITLE:=stress is a simple stress utility
   URL:=http://weather.ou.edu/~apw/projects/stress/
 endef
index 0276a3d..4364799 100644 (file)
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/testusb
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!LINUX_2_4 @DEVEL +libpthread
+  DEPENDS:=@DEVEL +libpthread
   TITLE:=USB testing utility
   URL:=http://www.linux-usb.org/usbtest/testusb.c
 endef