packages: add gpgme (closes: #9977)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 10:16:43 +0000 (10:16 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 10:16:43 +0000 (10:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29528 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gpgme/Makefile [new file with mode: 0644]

diff --git a/libs/gpgme/Makefile b/libs/gpgme/Makefile
new file mode 100644 (file)
index 0000000..4b78697
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gpgme
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/gpgme/
+PKG_MD5SUM:=90afa8436ce2b2683c001c824bd22601
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libgpgme
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=GnuPG Made Easy library
+  URL:=http://www.gnupg.org/
+  DEPENDS:=+gnupg +libassuan +libpthread
+endef
+
+define Package/libgpgme/description
+ GPGME (GnuPG Made Easy) is a C language library that allows to add
+ support for cryptography to a program. It is designed to make access to
+ public key crypto engines like GnuPG or GpgSM easier for applications.
+ GPGME provides a high-level crypto API for encryption, decryption,
+ signing, signature verification and key management.
+endef
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --with-gpg=/"usr/bin/gpg" \
+       --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
+       --with-libassuan-prefix="$(STAGING_DIR)/usr" \
+       --without-g13 \
+       --without-gpgconf \
+       --without-gpgsm \
+       --without-pth \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gpgme.h $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgpgme{,-pthread}.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libgpgme/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgpgme{,-pthread}.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgpgme))