Port srelay to -ng
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Aug 2006 14:42:57 +0000 (14:42 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Aug 2006 14:42:57 +0000 (14:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4537 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/srelay/Makefile [new file with mode: 0644]
net/srelay/files/srelay.conf [new file with mode: 0644]
net/srelay/files/srelay.init [new file with mode: 0755]
net/srelay/patches/01-cross_compile.patch [new file with mode: 0644]

diff --git a/net/srelay/Makefile b/net/srelay/Makefile
new file mode 100644 (file)
index 0000000..db1b2e2
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=srelay
+PKG_VERSION:=0.4.6
+PKG_RELEASE:=1
+PKG_MD5SUM:=4a9f3298b38d8588f0ffde31b946a47f
+
+PKG_SOURCE_URL:=@SF/socks-relay
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INIT_LEVEL:=60
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/srelay
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=A socks 4/5 proxy server
+  DESCRIPTION:=A socks 4/5 protocol proxy server
+  URL:=http://www.c-wind.com/srelay/
+endef
+
+define Package/srelay/conffiles
+/etc/srelay.conf
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--disable-thread)
+endef
+
+define Build/Compile
+$(call Build/Compile/Default, CC=$(TARGET_CC) \
+               all)
+endef
+
+define Package/srelay/install  
+       install -m0755 -d $(1)/usr/bin
+       install -m0755 -d $(1)/etc/init.d
+       $(CP) $(PKG_BUILD_DIR)/srelay $(1)/usr/bin/
+       $(CP) files/srelay.init $(1)/etc/init.d/S$(PKG_INIT_LEVEL)srelay
+       $(CP) files/srelay.conf $(1)/etc
+       chmod 755 $(1)/etc/init.d/S$(PKG_INIT_LEVEL)srelay
+endef
+
+$(eval $(call BuildPackage,srelay))
diff --git a/net/srelay/files/srelay.conf b/net/srelay/files/srelay.conf
new file mode 100644 (file)
index 0000000..e5d53ec
--- /dev/null
@@ -0,0 +1,2 @@
+# allow local subnet to access socks proxy
+192.168.1.0/24 any -
diff --git a/net/srelay/files/srelay.init b/net/srelay/files/srelay.init
new file mode 100755 (executable)
index 0000000..9e5a5f5
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ -f /etc/srelay.conf ];then
+       srelay -c /etc/srelay.conf -r -s 
+fi
diff --git a/net/srelay/patches/01-cross_compile.patch b/net/srelay/patches/01-cross_compile.patch
new file mode 100644 (file)
index 0000000..cda32e6
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN srelay-0.4.6/configure srelay-0.4.6.new/configure
+--- srelay-0.4.6/configure     2003-04-14 07:36:15.000000000 +0200
++++ srelay-0.4.6.new/configure 2006-03-28 15:11:42.000000000 +0200
+@@ -1395,7 +1395,7 @@
+       ;;
+   linux*)
+       case "$build_cpu" in
+-        i*86)
++        i*86 | mips* | powerpc* | sparc*)
+           OS=LINUX
+           cat >>confdefs.h <<\_ACEOF
+ #define LINUX 1