Add wdiag to -ng, closes #709
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Aug 2006 08:25:23 +0000 (08:25 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Aug 2006 08:25:23 +0000 (08:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4693 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/wdiag/Makefile [new file with mode: 0644]

diff --git a/net/wdiag/Makefile b/net/wdiag/Makefile
new file mode 100644 (file)
index 0000000..d2871ca
--- /dev/null
@@ -0,0 +1,44 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wdiag
+PKG_VERSION:=0.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=248bc2ca318f697e9edce1af945c57bd
+
+PKG_SOURCE_URL:=@SF/wdiag
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wdiag
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Westell DSL Modem Diagnostics for Linux
+  DESCRIPTION:=A collection of utilities to get DSL stats from Westell DSL modems.\\\
+  URL:=http://sourceforge.net/projects/wdiag/
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/src \
+       $(TARGET_CONFIGURE_OPTS) \
+       prefix="$(PKG_INSTALL_DIR)/usr"
+endef
+
+define Package/wdiag/install
+       install -m0755 -d $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/w{start,stop,estell} $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,wdiag))