libvorbis: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jul 2014 08:36:37 +0000 (08:36 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jul 2014 08:36:37 +0000 (08:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41715 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libvorbis/Makefile [deleted file]

diff --git a/libs/libvorbis/Makefile b/libs/libvorbis/Makefile
deleted file mode 100644 (file)
index 961c86e..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2008-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libvorbis
-PKG_VERSION:=1.3.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
-PKG_MD5SUM:=71b649d3e08e63ece16649df906ce8b9
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=COPYING
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libvorbis
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libvorbis
-  URL:=http://xiph.org/vorbis/
-  DEPENDS:=+libogg
-endef
-
-define Package/libvorbis/description
-Vorbis is a general purpose audio and music encoding format
-contemporary to MPEG-4's AAC and TwinVQ, the next generation beyond
-MPEG audio layer 3. Unlike the MPEG sponsored formats (and other
-proprietary formats such as RealAudio G2 and Windows' flavor of the
-month), the Vorbis CODEC specification belongs to the public domain.
-All the technical details are published and documented, and any
-software entity may make full use of the format without license
-fee, royalty or patent concerns.
-endef
-
-CONFIGURE_ARGS+= \
-       --disable-oggtest \
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/vorbis/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/vorbis/* $(1)/usr/include/vorbis/
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
-       $(INSTALL_DIR) $(1)/usr/share/aclocal/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
-endef
-
-define Package/libvorbis/install
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libvorbis))