oprofile: remove the kernel module package
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Feb 2011 01:13:45 +0000 (01:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Feb 2011 01:13:45 +0000 (01:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25692 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/oprofile/Makefile

index 2961e2d..d8de542 100644 (file)
@@ -22,18 +22,6 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-define KernelPackage/oprofile
-  SUBMENU:=Other modules
-  TITLE:=OProfile profiling support
-  KCONFIG:=CONFIG_OPROFILE @!LINUX_2_4
-  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
-  DEPENDS:=@KERNEL_PROFILING
-endef
-
-define KernelPackage/oprofile/description
-  Kernel module for support for oprofile system profiling.
-endef
-
 define Package/oprofile
   SECTION:=devel
   CATEGORY:=Development
@@ -97,4 +85,3 @@ endef
 
 $(eval $(call BuildPackage,oprofile))
 $(eval $(call BuildPackage,oprofile-utils))
-$(eval $(call KernelPackage,oprofile))